Bug 132706 - [RFE] mdadm could create raid devices that don't exist
[RFE] mdadm could create raid devices that don't exist
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
: FutureFeature
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-09-15 23:57 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 17:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-09-15 23:57:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
With udev, creating new raid devices is a bit of a pain, since the
device nodes are not there.  It would be nice if mdadm would create
them when given the -m number flag (or even infer the minor number
from the /dev/md%i pattern), if the named devices don't exist.

Version-Release number of selected component (if applicable):
mdadm-1.5.0-11

How reproducible:
Always

Steps to Reproduce:
1.mdadm -C /dev/md4 -n 1 -l 2 /dev/hdx1 /dev/hdy1

Actual Results:  /dev/md4 does not exist

Expected Results:  Before udev, we had plenty of raid devices already
present in /dev, and this just worked.  I wish it would work again.

Additional info:
Comment 1 Doug Ledford 2005-05-13 10:47:33 EDT
This is solved with mdadm-1.9.0-3.  Use the --auto=md flag to create a regular
md device file if it doesn't exist or use the --auto=mdp flag to create a
partitionable md device if it doesn't exist (but you have to use a name other
than /dev/md* when using partitionable devices, for example I created a 16
partition md device on an external FC array using this command:

[root@pe-fc4 ~]# mdadm -C /dev/fcarray -l 5 -n 4 --auto=mdp16 /dev/md0 /dev/md1
/dev/md2 /dev/md3

note that I used stacked md devices, and there are some bugs in stacked md
device handling in the mdadm-1.9.0 package, specifically it doesn't do mdadm -E
properly on stacked devices, but it does start them OK).
Comment 2 Alexandre Oliva 2005-05-13 15:03:36 EDT
I don't think the need for --auto=md is, well, auto enough.  If you're using one
of the standard device name, I can't think of any reason to not go ahead and
create the device if it's not there, since all the info can be inferred from the
device name.
Comment 3 Doug Ledford 2005-05-16 17:25:54 EDT
I changed the default setting of auto= to do as you wish.  As of
mdadm-1.11.0-2.fc4 in dist-FC4-HEAD this now works the way you want.

Note You need to log in before you can comment on or make changes to this bug.