Bug 13271 - rpm --ftpuseport remnant [patch]
Summary: rpm --ftpuseport remnant [patch]
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-30 13:00 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 20:49:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small patch to remove --ftpuseport (2.11 KB, patch)
2000-06-30 13:01 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2000-06-30 13:00:18 UTC
If you just type 'rpm', there is place where --ftpuseport is mentioned. 
This is probably just a leftover, and should mean --ftpport, because 
--ftpuseport isn't used anywhere in the code..

Translations need fixing too.

I'm sure this exists in 3.0.5 too, haven't checked though.

Comment 1 Pekka Savola 2000-06-30 13:01:03 UTC
Created attachment 838 [details]
Small patch to remove --ftpuseport

Comment 2 Jeff Johnson 2000-07-05 11:49:10 UTC
Fixed. Thanks for noticing.

Comment 3 Pekka Savola 2000-08-01 07:07:31 UTC
As of beta5, this would still appear to be an issue:

---
       rpm {--query -q} [-afpg] [-i] [-l] [-s] [-d] [-c] [-v] [-R]
                        [--scripts] [--root <dir>] [--rcfile <file>]
                        [--whatprovides] [--whatrequires] [--requires]
                        [--triggeredby] [--ftpport] [--ftpproxy <host>]
                        [--httpproxy <host>] [--httpport <port>] 
                        [--ftpport <port>] [--provides] [--triggers] [--dump]
                        [--changelog] [--dbpath <dir>] [targets]
---

Note that --ftpuseport was changed to --ftpport (as it should be), but the
parameter <port> is missing; two lines down the correct syntax is used.


Comment 4 Jeff Johnson 2000-08-04 20:49:45 UTC
This is fixed in CVS and in later-than-beta5 versions of rpm.

Comment 5 Pekka Savola 2000-08-10 15:12:00 UTC
Fine in RC1.


Note You need to log in before you can comment on or make changes to this bug.