This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 132715 - add support for nested lists to htmlbuffer.py
add support for nested lists to htmlbuffer.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
FC5
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2004-09-16 02:26 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 22:08:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-09-16 02:26:40 EDT
There are several unexpected line breaks at inappropriate places in
the release notes, as rendered by anaconda.  For example, the bullet
before GCC 3.4 or Gnome 2.8 has a line break between the bullet and
the text, which looks horrible.

The list of changed file names under X Window System doesn't have line
breaks at the right points, so it ends up totally unreadable.

Version-Release number of selected component (if applicable):
fedora-release-2.91-4 anaconda-10.0.2-4
Comment 1 Ed Bailey 2004-09-16 16:10:40 EDT
The misplaced bullets appear to be a bug in htmlbuffer.py when
handling multi-level nested lists.  The bullets at the point of
nesting are misplaced, and the nested list is not indented.

The run-together stuff in the X section was due to some stupid markup
I used.  I've fixed it, but since it uses nested lists you'll end up
seeing more misplaced bullets. :-(

Reassigning this to anaconda, so that htmlbuffer.py can be made a bit
smarter -- it absolutely needs to be able to handle lists nested
two-deep, and if it could be made to deal with lists nested three- or
four-deep, I'd be a happy man, indeed... :-)

FYI, The change in markup may not end up being reflected in test2,
depending on whether rel-eng decides to respin fedora-release...
Comment 2 Jeremy Katz 2004-09-16 16:42:49 EDT
Nested bullets aren't handled at this point and doing so isn't likely
to happen for fc3 (doing so requires a massive rework of how the html
widget works to not just simply apply pango attributes at the front
and back-end of things...)
Comment 3 Jeremy Katz 2006-02-28 22:08:51 EST
gtkhtml2 should handle these better

Note You need to log in before you can comment on or make changes to this bug.