Bug 1327171 - Disperse: Provide description of disperse.eager-lock option.
Summary: Disperse: Provide description of disperse.eager-lock option.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1435645 1435656
TreeView+ depends on / blocked
 
Reported: 2016-04-14 11:50 UTC by Ashish Pandey
Modified: 2017-08-17 08:22 UTC (History)
2 users (show)

Fixed In Version: 3.10.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1435645 1435656 (view as bug list)
Environment:
Last Closed: 2017-03-08 08:13:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ashish Pandey 2016-04-14 11:50:08 UTC
Description of problem:

Provide description of disperse.eager-lock option.
Similar option cluster.eager-lock for afr volume creates confusion.
Give a clear description and differentiate which option is for which type of volume. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-04-14 11:56:21 UTC
REVIEW: http://review.gluster.org/13999 (cluster/ec: Add/Modify description for eager-lock option) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 2 Vijay Bellur 2016-06-03 12:16:55 UTC
REVIEW: http://review.gluster.org/13999 (cluster/ec: Add/Modify description for eager-lock option) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 3 Vijay Bellur 2016-06-04 02:03:04 UTC
COMMIT: http://review.gluster.org/13999 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b347cf85300193ab83dcfaca63c39a4907fbf730
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Thu Apr 14 16:19:40 2016 +0530

    cluster/ec: Add/Modify description for eager-lock option
    
    This patch provides description for disperse.eager-lock
    option for disperse volume.
    
    It also modifies the description for cluster.eager-lock
    option to indicate that this option is only for replica
    volume.
    
    Change-Id: Ie73298947fcaaa6aaf825978bc2d27ceaff386d2
    BUG: 1327171
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/13999
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 4 Ashish Pandey 2017-08-17 08:22:34 UTC
*** Bug 1332516 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.