Bug 1327204 - Two network connections reported by nmcli during installation on s390x
Summary: Two network connections reported by nmcli during installation on s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 24
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1327169 (view as bug list)
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2016-04-14 12:43 UTC by Jan Stodola
Modified: 2016-08-19 19:50 UTC (History)
7 users (show)

Fixed In Version: NetworkManager-1.2.4-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 19:50:07 UTC
Type: Bug


Attachments (Terms of Use)
journalctl (182.99 KB, text/plain)
2016-04-14 12:44 UTC, Jan Stodola
no flags Details
nmcli c show uuid 07f02cc1-670c-4dd1-9ece-07a6ec94ac1b (3.88 KB, text/plain)
2016-04-14 12:44 UTC, Jan Stodola
no flags Details
nmcli c show uuid 9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d (2.88 KB, text/plain)
2016-04-14 12:45 UTC, Jan Stodola
no flags Details
[PATCH] device/ethernet: ignore s390 'portname' attribute when not set (2.07 KB, patch)
2016-04-15 08:17 UTC, Beniamino Galvani
no flags Details | Diff

Description Jan Stodola 2016-04-14 12:43:32 UTC
Description of problem:
During installation of Fedora 24 on s390x I can see two network connections:

[anaconda root@test ~]# nmcli c
NAME    UUID                                  TYPE            DEVICE 
enca00  07f02cc1-670c-4dd1-9ece-07a6ec94ac1b  802-3-ethernet  enca00 
enca00  9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d  802-3-ethernet  --     
[anaconda root@test ~]#

Version-Release number of selected component (if applicable):
NetworkManager-1.2.0-0.8.rc1.fc24

How reproducible:
always

Steps to Reproduce:
1. run installation on s390x

Actual results:
two network connections during the installation

Expected results:
just one network connection reported by nmcli

Additional info:
* the installation images were created locally by lorax-24.17-1.fc24, since there are no official F24 composes for s390x yet.

Comment 1 Jan Stodola 2016-04-14 12:44:02 UTC
Created attachment 1147234 [details]
journalctl

Comment 2 Jan Stodola 2016-04-14 12:44:58 UTC
Created attachment 1147235 [details]
nmcli c show uuid 07f02cc1-670c-4dd1-9ece-07a6ec94ac1b

Comment 3 Jan Stodola 2016-04-14 12:45:39 UTC
Created attachment 1147237 [details]
nmcli c show uuid 9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d

Comment 4 Beniamino Galvani 2016-04-15 08:17:16 UTC
Created attachment 1147497 [details]
[PATCH] device/ethernet: ignore s390 'portname' attribute when not set

This patch should fix the issue, but I was not able to test it (yet).

Comment 5 Thomas Haller 2016-04-22 14:05:41 UTC
(In reply to Beniamino Galvani from comment #4)
> Created attachment 1147497 [details]
> [PATCH] device/ethernet: ignore s390 'portname' attribute when not set
> 
> This patch should fix the issue, but I was not able to test it (yet).

lgtm

Comment 6 Francesco Giudici 2016-04-28 07:14:48 UTC
patch lgtm too

Comment 8 Jan Stodola 2016-05-10 12:07:52 UTC
I've built NM rpms with the patch applied and created new installation images - this issue is not reproducible with the patch applied. It also resolves the issue reported in bug 1327169, so I will close that bug as a duplicate of this one.

Comment 9 Jan Stodola 2016-05-10 12:09:18 UTC
*** Bug 1327169 has been marked as a duplicate of this bug. ***

Comment 10 Dan Horák 2016-05-10 12:41:36 UTC
Where can we expect an update for NetworkManager package? It's blocking proper testing of F-24 on s390x.

Comment 11 Jan Stodola 2016-05-18 11:14:48 UTC
ping, any update here, please?

Comment 12 Dan Horák 2016-05-18 11:28:38 UTC
We already have NetworkManager-1.2.2-1.fc24 built, is the fix there?

Comment 13 Beniamino Galvani 2016-05-18 12:15:00 UTC
(In reply to Dan Horák from comment #12)
> We already have NetworkManager-1.2.2-1.fc24 built, is the fix there?

Yes, it is.

Comment 14 Fedora Update System 2016-08-05 07:53:10 UTC
NetworkManager-1.2.4-1.fc24 network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 15 Fedora Update System 2016-08-05 21:21:45 UTC
NetworkManager-1.2.4-1.fc24, network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 16 Fedora Update System 2016-08-18 16:39:15 UTC
NetworkManager-1.2.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 17 Fedora Update System 2016-08-19 00:56:58 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 18 Fedora Update System 2016-08-19 10:29:23 UTC
network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 19 Fedora Update System 2016-08-19 19:49:43 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.