This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 132728 - Missing dependency declaration for openoffice-style-gnome
Missing dependency declaration for openoffice-style-gnome
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 08:47 EDT by Zenon Panoussis
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 09:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2004-09-16 08:47:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:

# rpm -qa |grep openoffice
openoffice.org-i18n-1.1.0-16.7.EL
openoffice.org-1.1.0-16.7.EL
openoffice.org-libs-1.1.0-16.7.EL
# rpm -Fhv openoffice.org-1.1.0-16.14.EL.i386.rpm \
  openoffice.org-libs-1.1.0-16.14.EL.i386.rpm \
  openoffice.org-i18n-1.1.0-16.14.EL.i386.rpm
error: Failed dependencies:
        /usr/lib/openoffice/program/getstyle-gnome is needed by
openoffice.org-1.1.0-16.14.EL
        /usr/lib/openoffice/program/msgbox-gnome is needed by
openoffice.org-1.1.0-16.14.EL
# rpm -qf /usr/lib/openoffice/program/getstyle-gnome
openoffice.org-1.1.0-16.7.EL
# rpm -qf /usr/lib/openoffice/program/msgbox-gnome
openoffice.org-1.1.0-16.7.EL
# rpm -qp --filesbypkg openoffice.org-1.1.0-16.14.EL.i386.rpm |grep
getstyle-gnome
#
# rpm -qp --filesbypkg openoffice.org-1.1.0-16.14.EL.i386.rpm |grep
msgbox-gnome
#
<scratching head>
# rpm -Uhv openoffice.org-1.1.0-16.14.EL.i386.rpm \
  openoffice.org-libs-1.1.0-16.14.EL.i386.rpm \
  openoffice.org-i18n-1.1.0-16.14.EL.i386.rpm \
  openoffice.org-style-gnome-1.1.0-16.9.EL.i386.rpm
(exit 0)

I assume this blocks up2date, but I can't tell that for sure.



Version-Release number of selected component (if applicable):
1.1.0-16.7.EL

How reproducible:
Always
Comment 1 Dan Williams 2004-09-16 09:29:50 EDT
Hmm, though if openoffice.org-style-gnome is available in the update
pool, RPM will be smart enough to grab it.

The problem here is that we cannot outright _require_
openoffice.org-style-gnome from the OOo packages (due to arch stuff,
we use the i386 OOo RPMs but the x86_64 style-gnome package on AMD64
for example), so we have to require the binary itself to make sure it
gets installed.

Jeremy, what's your take?
Comment 2 Jeremy Katz 2004-09-16 09:36:16 EDT
There's no bug here.  The dependency is there, just expressed as a
file dep instead of a package level dep.

Note You need to log in before you can comment on or make changes to this bug.