Bug 1327320 - unable to create docker container in external docker compute resource
Summary: unable to create docker container in external docker compute resource
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1324211
TreeView+ depends on / blocked
 
Reported: 2016-04-14 18:58 UTC by sthirugn@redhat.com
Modified: 2016-04-15 21:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-15 21:10:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
production.log (19.44 KB, text/plain)
2016-04-14 18:58 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2016-04-14 18:58:31 UTC
Created attachment 1147357 [details]
production.log

Description of problem:
unable to create docker container in external docker compute resource

Version-Release number of selected component (if applicable):
satellite-6.2.0-8.0.beta.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create an external docker compute resource
2. Create a docker product with one or more docker repo, publish/promote
3. Create a new container using the compute resource from step 1 and using the docker repos from step 2

Actual results:
Oops, we're sorry but something went wrong undefined method `full_messages' for []:Array

Expected results:
Docker container is created

Additional info:

Comment 3 Lukas Pramuk 2016-04-15 11:17:15 UTC
Possibly NOTABUG...

Do you have bootstrap certs installed on a remote docker host?

Comment 4 sthirugn@redhat.com 2016-04-15 13:15:45 UTC
@Lukas, thanks yeah this is what I  meant in Comment 2. I will get to this today.

Comment 5 sthirugn@redhat.com 2016-04-15 21:10:05 UTC
I created a new docker host and tried this again and it worked.

Fwiw, I used my docker Compute resource as http://$dockerhost:2375 and installed my katello cert in the docker host.  I was able to create a new container.


Note You need to log in before you can comment on or make changes to this bug.