Bug 1327327 - rpm -V tomcat fails on /var/log/tomcat/catalina.out
Summary: rpm -V tomcat fails on /var/log/tomcat/catalina.out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tomcat
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Coty Sutherland
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On: 1327326 1341853
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-14 19:34 UTC by Coty Sutherland
Modified: 2016-09-02 09:22 UTC (History)
6 users (show)

Fixed In Version: tomcat-7.0.70-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1327326
Environment:
Last Closed: 2016-09-02 09:22:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Coty Sutherland 2016-04-14 19:34:38 UTC
+++ This bug was initially created as a clone of Bug #1327326 +++

Description of problem:
When the command `rpm -V tomcat` is run, the verification test run on /var/log/tomcat/catalina.out fails. The PID file also fails because
of the change in mtime and probably should be ignored also.

Version-Release number of selected component (if applicable):
tomcat-7.0.65-1.el6.noarch

How reproducible: 
Always

Steps to Reproduce:
1. Install tomcat on RHEL 6 from the EL6 repository
2. Start the tomcat service
3. # rpm -V tomcat

Actual results:
S.5....T.    /var/log/tomcat/catalina.out
.......T.    /var/run/tomcat.pid

Expected results:
Do not include the catalina.out/tomcat.pid files because they will never be the same as what is installed, unless the service is never started.

Additional info:
Catalina.out and the pid file should pass verification, or not be included.

Comment 1 Coty Sutherland 2016-04-14 19:40:41 UTC
I opened this BZ for feedback from Ivan (or others) regarding my method of fixing it. Does anyone see a problem with this patch? Or any other files that should require verification changes?

https://github.com/csutherl/fedora-tomcat/commit/302781a

Comment 3 Fedora Update System 2016-08-05 20:10:58 UTC
tomcat-7.0.70-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3ff1f4485b

Comment 4 Fedora Update System 2016-08-09 02:18:04 UTC
tomcat-7.0.70-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3ff1f4485b

Comment 5 Fedora Update System 2016-09-01 16:20:18 UTC
tomcat-7.0.70-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2016-09-02 09:22:08 UTC
tomcat-7.0.70-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.