Bug 1327512 - munin-limits not reporting actual state of variable to NSCA
Summary: munin-limits not reporting actual state of variable to NSCA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kim B. Heino
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-15 09:38 UTC by Tom Yates
Modified: 2018-10-03 14:27 UTC (History)
3 users (show)

Fixed In Version: munin-2.0.40-4.fc28 munin-2.0.40-4.fc29 munin-2.0.40-4.el6 munin-2.0.40-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 17:28:37 UTC


Attachments (Terms of Use)

Description Tom Yates 2016-04-15 09:38:56 UTC
Description of problem:
Given a munin installation configured to report into NAGIOS via 
"contact.nagios.command /usr/sbin/send_nsca -H localhost -c /etc/nagios/send_nsca.cfg"
upgrading causes munin-limits to stop reporting the fourth field into send_nsca (the actual variable state).  This causes NAGIOS to interpret the results as host status checks instead of service status checks, which causes a LOT of freshness errors.

I've reconfigured munin to cat to file instead of sending to send_nsca, which is why I think the fourth field is missing.

Version-Release number of selected component (if applicable):
2.0.25-11

How reproducible:
Unsure

Steps to Reproduce:
1. Upgrade to munin-2.0.25-11
2. Run munin-limits --force


Actual results:
teaparty        mail throughput 0 
teaparty        eth0 traffic    0 
teaparty        df      0 

leading to NAGIOS logging

[1460701578] PASSIVE HOST CHECK: teaparty;0;0
[1460701578] PASSIVE HOST CHECK: teaparty;0;0
[1460701578] PASSIVE HOST CHECK: teaparty;0;0


Expected results:
teaparty        mail throughput 0       OKs: sent is 0.03.
teaparty        eth0 traffic    0       OKs: received is 4304.81, bps is 7974.01.
teaparty        df      0       OKs: / is 9.16, /boot is 19.81.

leading to NAGIOS logging

[1460710319] EXTERNAL COMMAND: PROCESS_SERVICE_CHECK_RESULT;teaparty;mail throughput;0;OKs: sent is 0.03.
[1460710319] EXTERNAL COMMAND: PROCESS_SERVICE_CHECK_RESULT;teaparty;eth0 traffic;0;OKs: received is 4304.81, bps is 7974.01.
[1460710319] EXTERNAL COMMAND: PROCESS_SERVICE_CHECK_RESULT;teaparty;df;0;OKs: / is 9.16, /boot is 19.81.


Additional info:

Comment 1 d. johnson 2016-04-16 00:34:18 UTC
Have you filed this bug with upstream?

https://github.com/munin-monitoring/munin/issues

Comment 2 Tom Yates 2016-04-16 08:21:49 UTC
I haven't; I wasn't sure that the issue was in upstream, not the repackaging.  I am happy to file with upstream if you can give me that assurance.

Comment 3 Tom Yates 2016-04-21 08:29:32 UTC
Not least because the problem wasn't there in munin 2.0.25-2, and downgrading to those packages immediately fixed the problem.   If I understand the numbering correctly, the differences there are entirely EPEL's - munin just releases 2.0.25.

Comment 4 d. johnson 2016-04-22 01:21:20 UTC
Not entirely accurate, 2.0.25-5 integrated the pre-2.0.26 patches that have not been released yet. They have not changed either, so the author was OK with a pre-release patch until he was ready to release 2.0.26.

Comment 5 Tom Yates 2016-04-25 08:29:33 UTC
That makes sense (thank you!), but as far as I can tell from https://github.com/munin-monitoring/munin/releases 2.0.26 was never released, so I'm not entirely sure what I'm supposed to log with upstream.  If anything, it seems to me like upstream are moving towards a 3.0 release (their dev release is *way* past 2.1, currently at 2.999.2).  Perhaps epel should back out the 2.0.26-inspired changes, and hold fire until upstream release a new production version?

Comment 6 Tom Yates 2018-08-24 10:24:55 UTC
OK, the problem is in upstream, I've just built 2.0.39 on CentOS 7 and I have the same problem.

I have logged this with them at https://github.com/munin-monitoring/munin/issues/1052 .

Comment 7 Tom Yates 2018-08-28 08:21:34 UTC
Upstream have produced a (three-line) patch which works for me with C6 and EPEL munin 2.0.33-1.  Having restored EPEL munin to my (one and only) C7 server, I can confirm it works there, too.

Interestingly, upstream say the regression was introduced in 2.0.26, which fits with the timing we see.

Comment 8 Kim B. Heino 2018-09-15 07:50:47 UTC
Upstream patch at:

https://github.com/munin-monitoring/munin/commit/f0fa843b34918a43e312777037c762d5638af275

It will be included in 2.0.41.

Comment 9 Fedora Update System 2018-09-17 10:55:15 UTC
munin-2.0.40-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-673f52b139

Comment 10 Fedora Update System 2018-09-17 10:55:31 UTC
munin-2.0.40-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6455129fce

Comment 11 Fedora Update System 2018-09-17 10:55:45 UTC
munin-2.0.40-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39b27a8592

Comment 12 Fedora Update System 2018-09-17 10:56:00 UTC
munin-2.0.40-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf0c049faf

Comment 13 Fedora Update System 2018-09-17 18:51:03 UTC
munin-2.0.40-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-673f52b139

Comment 14 Fedora Update System 2018-09-17 19:11:45 UTC
munin-2.0.40-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf0c049faf

Comment 15 Fedora Update System 2018-09-17 19:24:38 UTC
munin-2.0.40-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6455129fce

Comment 16 Fedora Update System 2018-09-18 06:16:52 UTC
munin-2.0.40-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39b27a8592

Comment 17 Fedora Update System 2018-09-27 17:28:37 UTC
munin-2.0.40-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-09-27 18:01:03 UTC
munin-2.0.40-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-10-03 13:47:24 UTC
munin-2.0.40-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-10-03 14:27:21 UTC
munin-2.0.40-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.