Bug 132770 - speedup patch for vte (makes gnome-terminal usable again)
speedup patch for vte (makes gnome-terminal usable again)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 110154 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-16 16:06 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 16:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
make vte go fast (zoom, zoom) (13.46 KB, patch)
2004-09-16 16:07 EDT, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Tom "spot" Callaway 2004-09-16 16:06:38 EDT
The patch found here: http://bugs.gnome.org/show_bug.cgi?id=143914

is a serious performance improvement for vte, and thus, gnome-terminal.

For example, this is the output of time ls -R in the BUILD/vte-0.11.11
directory before the patch:

real    0m0.441s
user    0m0.010s
sys     0m0.013s

...and after the patch:

real    0m0.079s
user    0m0.013s
sys     0m0.006s

Thats roughly an 82% performance increase.

Attached is a version of this patch, ready to apply to rawhide vte.
Comment 1 Tom "spot" Callaway 2004-09-16 16:07:32 EDT
Created attachment 103930 [details]
make vte go fast (zoom, zoom)
Comment 2 Havoc Pennington 2004-10-27 23:39:44 EDT
Ouch, definitely should have had this one on the target list. Too late
for FC3, but adding it to target list anyhow and we can do it as an
update or be sure it gets migrated to the FC4 target list.
Comment 3 Warren Togami 2004-10-27 23:50:38 EDT
What about RHEL4?
Comment 4 Dax Kelson 2004-10-28 01:27:22 EDT
I don't think that 'ls -R' is a very accurate benchmarking tool.
Waaaay to many kernel caching things can effect it.

[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.323s
user    0m0.185s
sys     0m0.077s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.303s
user    0m0.203s
sys     0m0.091s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.381s
user    0m0.265s
sys     0m0.098s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.464s
user    0m0.308s
sys     0m0.136s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.599s
user    0m0.409s
sys     0m0.149s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.810s
user    0m0.545s
sys     0m0.203s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.798s
user    0m0.538s
sys     0m0.208s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.772s
user    0m0.539s
sys     0m0.200s
[dkelson@mentorng dkelson]$
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.774s
user    0m0.535s
sys     0m0.207s
[dkelson@mentorng dkelson]$ time ls -R /usr/lib > /dev/null
 
real    0m0.787s
user    0m0.550s
sys     0m0.197

To benchmark vte (which I'm greatly in favor of speeding up), make
your gnome-terminal 25x80 then do:

$ time cat /usr/share/dict/linux.words

Run this several times, and discard the first couple results.

BTW, if your X server has a hardware accelerated Xrender extension
then vte get a very nice boost in performance. I could be wrong, but I
think only the binary-only Nvidia drivers fit that criteria.
Comment 5 Panu Matilainen 2004-10-28 07:53:48 EDT
Well this indeed is quite a dramatic improvement. 
"time cat /usr/share/mime-info/gnome-vfs.keys", originally:
real    0m11.588s
user    0m0.000s
sys     0m0.030s
..and with this patch applied:
real    0m0.836s
user    0m0.000s
sys     0m0.040s

And that's with the file hot in cache and the result is consistent
over consecutive runs. This, um, kicks some serious butt :)
Comment 6 Dan Williams 2004-10-31 23:14:29 EST
Ray, can we toss this into rawhide at least?
Comment 7 Warren Togami 2004-10-31 23:35:16 EST
Been testing it for a few days, it seems good.
Comment 8 Ray Strode [halfline] 2004-11-01 16:06:16 EST
Should be in rawhide now
Comment 9 Warren Togami 2004-11-15 21:14:31 EST
*** Bug 110154 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.