Bug 1327722 - provisioning error in $evm.execute('create_provision_request', *args)
Summary: provisioning error in $evm.execute('create_provision_request', *args)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.5.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.5.5
Assignee: Drew Bomhof
QA Contact: Milan Falešník
URL:
Whiteboard: ldap:automate:provision
Depends On: 1322876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-15 18:17 UTC by John Prause
Modified: 2019-10-10 11:53 UTC (History)
9 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, provisioning with the out of the box admin account was successful but provisioning with an ldap user failed. This was because the logic in the create_provision_request (ultimately the class method from_ws_ver_1_x in miq_provision_virt_workflow.rb) was modified as part of the tenant work to validate the requested user_name value existed in the database so the request could be assigned to the proper user/group/tenant. This update now uses lookup_by_identity to validate a user parameter and the issue is now resolved.
Clone Of: 1322876
Environment:
Last Closed: 2016-07-26 15:32:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 4 Milan Falešník 2016-07-18 09:18:42 UTC
Verified that the user resolution using both name and name@domain works in 5.5.5.2

I user the username and it correctly found out the user in AD. The created user in the Access Control has name@domain in there. Then I tried it again with the name@domain and it worked too.

Comment 6 errata-xmlrpc 2016-07-26 15:32:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.