Bug 1327729 - Setting Image Metadata for an Image is accepting number, where it should accept only String (True/False)
Summary: Setting Image Metadata for an Image is accepting number, where it should acce...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-15 18:24 UTC by Tanay Ganguly
Modified: 2017-07-30 15:29 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.2-1.el7cp Ubuntu: ceph_10.2.2-3redhat1xenial
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:36:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Tanay Ganguly 2016-04-15 18:24:04 UTC
Description of problem:
Setting Image Metadata for an Image is accepting number, where it should accept only String

Version-Release number of selected component (if applicable):
10.1.1.1

How reproducible:
NA

e.g.

rbd image-meta set Tanay-RBD/CLOOONE1 rbd_cache_writethrough_until_flush 512
rbd image-meta set Tanay-RBD/CLOOONE1 rbd_cache 1024

rbd_cache_writethrough_until_flush and rbd_cache should accept only True and False, rather it is accepting numeric value as well.

Comment 2 Ken Dreyer (Red Hat) 2016-04-26 21:09:03 UTC
Jason, would you be able to land a fix in jewel upstream a week from now (May 2nd)?

Comment 3 Jason Dillaman 2016-04-26 22:00:50 UTC
Ken: highly unlikely to land next week.

Comment 4 Ken Dreyer (Red Hat) 2016-04-27 00:02:21 UTC
Ok, I recommend we re-target to RHCS 2.1. Neil/Federico?

Comment 5 Neil Levine 2016-05-06 20:07:41 UTC
+1

Comment 6 Jason Dillaman 2016-05-27 19:23:23 UTC
Upstream PR: https://github.com/ceph/ceph/pull/9280

Comment 11 Jason Dillaman 2016-06-12 23:58:31 UTC
Merged, upstream Jewel PR: https://github.com/ceph/ceph/pull/9554

Comment 19 errata-xmlrpc 2016-08-23 19:36:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.