Bug 132773 - All content within a <step> element is elided in the Fedora Docs stylesheets
All content within a <step> element is elided in the Fedora Docs stylesheets
Status: CLOSED WORKSFORME
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 16:38 EDT by Dave Malcolm
Modified: 2009-07-07 00:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-27 08:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2004-09-16 16:38:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Within the Stateless Linux HOWTO source, I had some content of this form:
<step>
  <title>Do something</title>
  <para>Some text</para>
  <para>Some more text</para>
</step>

When I ran Make to generate an HTML version of the DocBook, all of the
elements within each <step> element appeared in one block without
linebreaks.  This ruined the readability of the output, since I got
huge paragraphs, rather than a series of manageable ones.  The title
elements looked wrong as well.  (It was worked around by putting each
para into its own step inside substeps, but I believe the problem remains)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try this input (haven't checked it, I'm afraid):
<article>
<procedure>
<step>
  <title>Do something</title>
  <para>Some text</para>
  <para>Some more text</para>
</step>
</procedure>
</article>

Now view the generated html

Additional info:
Comment 1 Paul W. Frields 2004-09-17 13:11:06 EDT
I tested this. It's definitely *not* broken in a generic "xmlto," i.e.:

   xmlto html test.xml

It only happens if I build in our FDP environment. Something to do
with our surrounding "stuff" (sorry, not an XSLT or any other related
tool expert here) is breaking the proper behavior.
Comment 2 Tammy Fox 2004-09-30 12:40:02 EDT
Dave, are you still seeing this problem? I just built your doc and
didn't see it. We haven't seen this before since we usually use
<orderedlist> instead of <procedure> and <step>.
Comment 3 Paul W. Frields 2004-11-26 11:15:47 EST
I'm still seeing this behavior under FC3 and using an updated copy of
the fedora-docs CVS stuff.
Comment 4 Tammy Fox 2004-11-30 21:35:27 EST
Hi Paul. Will you attach the test document you used to reproduce this
on FC3? Thanks.
Comment 5 Paul W. Frields 2005-08-19 23:18:41 EDT
Here is the document in its entirety, hoping it reproduces in Bugzilla OK:

<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
 "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [

]>
<article>
  <procedure>
    <step>
      <title>Do something</title>
      <para>Some text</para>
      <para>Some more text</para>
    </step>
  </procedure>
</article>
Comment 6 Paul W. Frields 2005-11-27 08:52:59 EST
This is working properly.  Closing.
Comment 7 eric@christensenplace.us 2009-07-07 00:08:43 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.