Bug 132779 - smb.conf should use sendfile=no by default
smb.conf should use sendfile=no by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-16 17:42 EDT by Zack Cerza
Modified: 2014-08-31 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 11:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2004-09-16 17:42:01 EDT
The fact that samba's sendfile causes problems isn't new to you. I
propose that 'use sendfile=no' be put in [global] by default.
Comment 1 Steve French 2004-10-05 17:46:35 EDT
samba 3.0.x code already sets sendfile off (no matter what smb.conf 
says) for clients prior to NT4 and when the local tcp sendfile API 
return ENOSYS and when smb signing is enabled.  This should cover all 
of the obvious reasons why samba should not attempt sendfile.

Are there known problems with the tcp sendfile API in particular 
versions of the kernel itself?

I don't know if the ltp or other tests include a simple functional 
test for sendfile but that sounds like an obvious next step.
Comment 2 Jay Fenlason 2005-04-07 11:09:27 EDT
More recent versions of Samba have defaulted to "use sendfile = no" unless 
explicitly overridden in the smb.conf file.  Since we don't set it in the 
default smb.conf, we're set. 

Note You need to log in before you can comment on or make changes to this bug.