Bug 13279 - Cannot `su' with 37 groups
Cannot `su' with 37 groups
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-30 13:13 EDT by Bob Apodaca
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-30 13:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Apodaca 2000-06-30 13:13:19 EDT
We use NIS here with user `root' in almost every group in our NIS
/etc/group file.  On our workstations, we cannot su to root:

bash>/bin/su -
Password: 
/bin/su: cannot set groups: Invalid argument

I believe the problem is that there is a limit of 32 groups in glibc and
this is preventing me from su'ing to root.
Comment 1 Jakub Jelinek 2000-08-25 11:55:31 EDT
This is actually kernel limitation. You can rebuild kernel (and glibc as well)
yourself to up that limit, in the kernel it is in linux/limits.h and asm/params.h,
in glibc you'll just need to make sure the updated kernel headers are installed
in the system before recompiling glibc. Note however that increasing that
value will eat up space in every tasks' task_struct.
It has no point in increasing this generally when 99.99% people will not need
it and it would just decrease the kernel stack for them.

Note You need to log in before you can comment on or make changes to this bug.