Bug 1327951 - Upgraded samba 4.2.10 packages cause OS X guest mounts to fail
Summary: Upgraded samba 4.2.10 packages cause OS X guest mounts to fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-18 06:46 UTC by Toni Spets
Modified: 2016-11-04 07:00 UTC (History)
7 users (show)

Fixed In Version: samba-4.4.4-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:00:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2468 normal SHIPPED_LIVE samba bug fix and enhancement update 2016-11-03 14:06:51 UTC
Samba Project 11847 None None None 2016-04-19 06:55:47 UTC

Description Toni Spets 2016-04-18 06:46:36 UTC
Description of problem:

After upgrading to new samba packages, OS X clients cannot authenticate as guests making local public network shares inaccessible.


Version-Release number of selected component (if applicable):

Apr 18 08:14:06 Updated: samba-libs-4.2.10-6.el7_2.x86_64
Apr 18 08:14:07 Updated: samba-common-tools-4.2.10-6.el7_2.x86_64
Apr 18 08:14:07 Updated: samba-common-4.2.10-6.el7_2.noarch
Apr 18 08:14:07 Updated: samba-client-libs-4.2.10-6.el7_2.x86_64
Apr 18 08:14:07 Updated: samba-common-libs-4.2.10-6.el7_2.x86_64
Apr 18 08:14:09 Updated: samba-4.2.10-6.el7_2.x86_64


How reproducible:

Immediately after upgrade without any configuration changes. Windows and Linux clients can mount and work with the shares as usual.


Steps to Reproduce:
1. Upgrade to latest EL 7.2 samba packages
2. Try to mount a guest mountable network share using OS X Yosemite

Actual results:

OS X clients fail to mount with a generic error: 'There was a problem connecting to the server "<address>".'

Expected results:

Share mountable and browsable.

Additional info:

First encounter on production CentOS 7 server. Downgrading back to following packages works around the problem:

Apr 18 09:08:01 Installed: samba-libs-4.2.3-12.el7_2.x86_64
Apr 18 09:08:01 Installed: samba-common-tools-4.2.3-12.el7_2.x86_64
Apr 18 09:08:01 Installed: samba-common-4.2.3-12.el7_2.noarch
Apr 18 09:08:02 Installed: samba-client-libs-4.2.3-12.el7_2.x86_64
Apr 18 09:08:02 Installed: samba-common-libs-4.2.3-12.el7_2.x86_64
Apr 18 09:08:02 Installed: samba-4.2.3-12.el7_2.x86_64

I have confirmed this on up-to-date RHEL 7 VM with the developer license using identical package versions and epochs including downgrading.

Comment 2 Luc Lalonde 2016-05-11 18:51:17 UTC
Hello...

I have the same problem...  We use our Samba fileserver for homedirs and profils in our Windows and Mac labs.

With this version of Samba, the Mac login session would lock-up and multiple 'smbd' with 100% CPU usage!

If I haden't notice this so quickly all our labs (Linux, Windows, Mac) would have been unuseable!

I grabbed the SRPMS from Fedora 24 testing and recompiled:

samba-winbind-4.4.3-1.el7.centos.x86_64
samba-client-libs-4.4.3-1.el7.centos.x86_64
samba-winbind-krb5-locator-4.4.3-1.el7.centos.x86_64
samba-common-tools-4.4.3-1.el7.centos.x86_64
samba-client-4.4.3-1.el7.centos.x86_64
samba-common-4.4.3-1.el7.centos.noarch
samba-libs-4.4.3-1.el7.centos.x86_64
samba-common-libs-4.4.3-1.el7.centos.x86_64
samba-4.4.3-1.el7.centos.x86_64
samba-winbind-modules-4.4.3-1.el7.centos.x86_64

Everything works correctly now (CentOS 7.2).

Cheers!

Comment 3 Brent Kolasinski 2016-05-31 21:01:12 UTC
This is affecting me as well.  It appears that Debian has committed a fix to their packages last week:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=821730

The samba team also has committed a patch for this:
https://attachments.samba.org/attachment.cgi?id=12045 
https://bugzilla.samba.org/show_bug.cgi?id=11849

I am experiencing this problem on OS X hosts running 10.9-10.11.  In the mean time, I'll need to compile srpms from the Fedora Project, which is not a great solution in the long run.

I have also file a bug report with CentOS, which can be viewed here:
https://bugs.centos.org/view.php?id=10935


Thanks!

Comment 8 errata-xmlrpc 2016-11-04 07:00:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2468.html


Note You need to log in before you can comment on or make changes to this bug.