Bug 132801 - openldap cannot handle modify during large searches
openldap cannot handle modify during large searches
Status: CLOSED DUPLICATE of bug 132800
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openldap (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 03:51 EDT by Håkan Wessberg
Modified: 2015-01-07 19:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Håkan Wessberg 2004-09-17 03:51:19 EDT
Description of problem:
We have 80.000 entries in a ldbm backend database and cant make
search and modify concurrently. This causes serious problems when
large reads are made that take aprox 4-5 min. During those reads we
cant make any writes and the client that tries to do so hangs until
the read is finished.


Version-Release number of selected component (if applicable):
openldap-2.0.27-17

How reproducible:
Always

Steps to Reproduce:
1. search for a large group of objects.
2. try to modify one object (not necessarily one in the group returned
by the search)
3.
    

Actual Results:  the modify is not performed until all objects is
returned from the search-operation.

Expected Results:  both search and modify should happen conccurently.

Additional info:

Kurt Zeilenga, of openldap fame, responded with when this report was
posted to the openldap-bugs list:
"Trying upgrading.  2.0, as well as 2.1, are considered Historic."

When is RH ready to offer a recent version of openldap?
Comment 1 Håkan Wessberg 2004-09-17 03:52:21 EDT

*** This bug has been marked as a duplicate of 132800 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.