Bug 132802 - RPC headers not 64bit ready
RPC headers not 64bit ready
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 04:29 EDT by Harald Hoyer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 03:12:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2004-09-17 04:29:56 EDT
u_long is used in all the RPC headers

They should be defined correctly like here:
http://cvsup.pt.freebsd.org/cgi-bin/cvsweb/cvsweb.cgi/src/include/rpc/#dirlist
Comment 2 Jakub Jelinek 2004-09-24 03:12:04 EDT
We discussed this on IRC.
1) the headers can't change because of binary compatibility requirements
2) the structures in those headers are the host structures, which by
   no means have to reflect the layout that goes over the wire.
   tcpdump should use xdrmem* RPC accessors.

Note You need to log in before you can comment on or make changes to this bug.