Bug 132828 - Xaw3d shared libs can't be dropped in place of Xaw libs
Xaw3d shared libs can't be dropped in place of Xaw libs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Xaw3d (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 11:30 EDT by Bryan Wright
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 08:51:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Wright 2004-09-17 11:30:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040507

Description of problem:
	Under earlier distributions, I've always been able to
replace the Xaw shared libs with the equivalent Xaw3d libs.  This
is a quick way of prettying up some older X applications (xterm, xcalc,
xfig, etc.)  For some reason, this doesn't seem to work under FC2.

	Normally, I'd just do this:

	mv libXaw.so.7.0 /some/where/safe/
	cp -f libXaw3d.so.7.0 libXaw.so.7.0
	ldconfig -v

and, voila!, xterm gets a 3-d scroll bar.

	Under FC2 though, xterm complains that it can't find libXaw.so.7.
It turns out that ldconfig is indeed failing to create the symbolic
link from libXaw.so.7 to libXaw.so.7.0.  Creating the link by hand
doesn't solve the problem, though.  Typing 'ldd /usr/bin/xterm' still
shows
libXaw.so.7 as missing.

	At first I thought it might be a problem with prelinking,
so I did a 'prelink -u /usr/bin/xterm'.  That didn't seem to make
any difference.


Version-Release number of selected component (if applicable):
Xaw3d-1.5-21.1

How reproducible:
Always

Steps to Reproduce:
1. mv libXaw.so.7.0 /some/where/safe/
2. cp -f libXaw3d.so.7.0 libXaw.so.7.0
3. ldconfig -v
4. Try to run xterm
    

Actual Results:  xterm complains that it can't find libXaw.so.7

Expected Results:  xterm should acquire nifty 3-d scrollbar.

Additional info:
Comment 2 Jakub Jelinek 2004-11-30 08:45:32 EST
No, that's the right behaviour.  libXaw3d.so.7.0 has libXaw3d.so.7 SONAME,
see readelf -d liBXaw3d.so.7.0 | grep SONAME
ldconfig will in this case create libXaw3d.so.7 -> libXaw.so.7.0 symlink
(well, when you have two different libraries with the same SONAME in one
directory, only one will win).
So, if you want to do this, you'd need to cp -f libXaw3d.so.7.0 libXaw.so.7.
Comment 3 Ngo Than 2004-11-30 08:51:41 EST
Jakub, many thanks for your statements ;-) i'm closing it as notabug

Note You need to log in before you can comment on or make changes to this bug.