Bug 132831 - autofs automounted filesystems inexplicably become unavailable
autofs automounted filesystems inexplicably become unavailable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 11:36 EDT by Paul Waterman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 14:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Waterman 2004-09-17 11:36:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
With the new version of autofs included in RHEL 3.0-U3, automounted
filesystems inexplicably become unavailable.

It appears that the mount is in some sort of weird limbo, where some
parts of the system believe that the filesystem is mounted, but other
parts of the filesystem believe it isn't.

When the automount is in this limbo state, attempts to access the
filesystem generate messages in /var/log/messages such as the following:

Sep 17 10:19:53 lnxtst04 automount[15355]: BUG: /apps/vendor/bin
already mounted

The problem can be resolved by issuing a manual umount command;
subsequent attempts to access the automount filesystem will cause it
to successfully be automounted and become available.

The following shows a real-world example of this problem occuring
(/apps/vendor/bin is an automounted filesystem):

% ls /apps/vendor/bin
./  ../

(lnxtst04 : root : /var/log)
% df -k /apps/vendor/bin
Filesystem           1K-blocks      Used Available Use% Mounted on
ahfil03:/vol/vol0_03/software/vendor/bin
                             0         0         0   -  /apps/vendor/bin

(lnxtst04 : root : /var/log)
% grep "/apps/vendor/bin" /proc/mounts

(lnxtst04 : root : /var/log)
% umount /apps/vendor/bin
umount: /apps/vendor/bin: not mounted

(lnxtst04 : root : /var/log)
% ls /apps/vendor/bin
./               bstop@       hpgltomif@  jarsigner@        kwinsight@
  matlab*      rose*        tmsbrowser@
../              bsub@        iaftomif@   java*             kwinspect@
  mmltomif@    rose2000@    trofftomif@
.snapshot/       cleartool*   idu@        javac@            kwjava@  
   mozilla*     rose2001@    viewer@
REPnewconfname@  codewizard*  igestomif@  javadoc@          kwlinker@
   netscape@    rose2002@    win2k*
acroexch*        cwmfs@       iiusers@    javah@            lbrun*   
   ntperl*      rose2003@    win2k.pl*
acroread*        distill@     ileaf*      javap@           
lbrun.bsub*  picttomif@   rose98i@     winnt@
appletviewer@    doors*       ileaf5@     jdb@              lshosts@ 
   pl2ps@       rulewizard@  wordtomif@
bbot@            dxftomif@    ileaf6@     keytool@          lsid@    
   policytool@  smallxd@     wptomif@
bhist@           edgcfe@      ileaf7@     kmc@              lsinfo@  
   pslic@       tau*         xdesigner*
bhosts@          flexelint*   ileaffilt@  kwadmin@          lsload@  
   psrcdump@    tau4.2cc@    xwd8to1@
bjobs@           fmbatch@     ins_pp@     kwcc*             maker*   
   ptk*         tau4.4@
bkill@           fmclient@    insra@      kwcreatemodel@    maker5@  
   qsilver@     tau4.4.4@
bqueues@         fminvert@    is1tomif@   kwcreatesembase@  maker6@  
   reader@      tau4.5@
bresume@         fmprint@     jar@        kwinforce@        maker7@  
   rm8tomif@    teamplayer*

(lnxtst04 : root : /var/log)
% df -k /apps/vendor/bin
Filesystem           1K-blocks      Used Available Use% Mounted on
ahfil03:/vol/vol0_03/software/vendor/bin
                      36700160  18846240  17853920  52% /apps/vendor/bin

(lnxtst04 : root : /var/log)
% grep "/apps/vendor/bin" /proc/mounts
ahfil03:/vol/vol0_03/software/vendor/bin /apps/vendor/bin nfs
ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=ahfil03 0 0


Version-Release number of selected component (if applicable):
autofs-4.1.3-12

How reproducible:
Sometimes

Steps to Reproduce:
1. Access an automounted filesystem
2. Wait -- the problem will eventually occur
    

Actual Results:  See the description above.

Expected Results:  The automounted filesystem should remain available.

Additional info:
Comment 1 Jeffrey Moyer 2004-09-20 15:39:38 EDT
What is the version of the kernel you are using?  Please also post the
output of lsmod.

Thanks!
Comment 2 Paul Waterman 2004-09-20 16:31:33 EDT
All components on the test system where we're seeing this problem are
vanilla RHEL 3.0-U3.

Kernel version = 2.4.21-20.ELsmp

% lsmod
Module                  Size  Used by    Tainted: PF 
sr_mod                 17784   0 (autoclean) (unused)
ide-cd                 34016   0 (autoclean)
cdrom                  32544   0 (autoclean) [sr_mod ide-cd]
vmnet                  25376   4
vmmon                  42996  14
nfs                    99376  10 (autoclean)
lockd                  58992   1 (autoclean) [nfs]
mvfs                  309056 119
vnode                  76116 119 [mvfs]
sunrpc                 89212   1 [nfs lockd vnode]
autofs                 13620   7 (autoclean)
audit                  90552   3
tg3                    65832   1
floppy                 57488   0 (autoclean)
sg                     37228   0 (autoclean)
microcode               6848   0 (autoclean)
keybdev                 2976   0 (unused)
mousedev                5624   1
hid                    22276   0 (unused)
input                   6144   0 [keybdev mousedev hid]
usb-ohci               23176   0 (unused)
usbcore                81056   1 [hid usb-ohci]
ext3                   89960   2
jbd                    55060   2 [ext3]
megaraid               30604   3
sd_mod                 13712   6
scsi_mod              114344   4 [sr_mod sg megaraid sd_mod]
Comment 3 Jeffrey Moyer 2004-09-20 16:34:16 EDT
You aren't using the autofs4 kernel module.  Please do the following:

service autofs stop
rmmod autofs
service autofs start

After that, an lsmod *should* show autofs4.  If it doesn't, you can
add the following line to your /etc/modules.conf:

alias autofs autofs4

Please try this and let me know if the problem persists.

Thank you.
Comment 4 Paul Waterman 2004-09-24 11:33:07 EDT
Ah-hah. The /etc/rc.d/init.d/autofs script for autofs v4 had
significant updates to it. We use a customized version of the autofs
init script to compute and set localoptions: Using the old autofs (v3)
init script loads the wrong autofs module.

Looks like we'll have to edit our customizations into the new autofs
init script.
Comment 5 Jeffrey Moyer 2004-09-24 11:36:30 EDT
Does running the autofs4 kernel module fix your problem?  You don't
specifically say it does. ;)  I'm going to keep this open until I get
confirmation.  If this is a bug, we need to address it.

Also, what are the custom changes that you maintain?  Perhaps we can
get them put into the rpm or upstream if they are applicable to others.

-Jeff
Comment 6 Paul Waterman 2004-09-24 14:39:45 EDT
:)

To clarify: With the normal autofs-4.1.3-12 init script, the autofs4
kernel module is properly loaded instead of the autofs kernel module.
With the autofs4 kernel module, we no longer experience the problem
described initially within this bug.

Regarding our customizations:

A couple of our customizations are to force our Linux systems to
ignore certain legacy NIS automount maps -- these are pretty specific
to us (and we may not even need them any more; I'll need to check).

The more important customization is that we set the "localoptions"
variable ("LOCALOPTIONS" in the v4 script) so that we can mount
different filesystems depending on the OS and OS version.

Looking at the autofs v4 init script, though, it looks like an
improvement has already been made here: LOCALOPTIONS can now be set in
/etc/sysconfig/autofs, which means we can maintain that without
modifying the autofs init script itself.
Comment 7 Jeffrey Moyer 2004-09-24 14:48:59 EDT
Okay, then I'll close this bug.  Thank you for clarifying.

As a side note, there is a feature request for something that sounds
like it may work for you.  Please take a look at bz #91559:
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91559

If that sounds like what you need, please let me know.  Multiple
people requesting a feature bumps it up on my list.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.