Bug 1328342 - [tiering]: gluster v reset of watermark levels can allow low watermark level to have a higher value than hi watermark level
Summary: [tiering]: gluster v reset of watermark levels can allow low watermark level ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1315583
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-19 07:44 UTC by hari gowtham
Modified: 2017-05-30 18:34 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1315583
Environment:
Last Closed: 2017-05-30 18:34:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2016-04-19 07:44:56 UTC
+++ This bug was initially created as a clone of Bug #1315583 +++

Description of problem:

Resetting only one of the watermark level (either low watermark or high watermark) allows system to have a higher low watermark than high water mark.

For ex, when low and hi watermarks are set at 10% and 30% respectively and when low watermark is reset using 'gluster v reset <vol name> cluster.watermark-low' command, watermark levels become 75% and 30% for low and high watermarks respectively.

Resetting watermark levels should always done in pair, i.e., when one of the watermark level is attempted to reset, a warning should be thrown that this will reset both low and hi watermarks and the watermarks should be reset together to default 75% and 90%

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-19.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. create a tiered volume
2. set watermarks level to 10% and 30% 

# gluster v set testvol cluster.watermark-low 10
# gluster v set testvol cluster.watermark-hi 30

3. Reset cluster.watermark-low

# gluster v reset tiervol cluster.watermark-low

Actual results:
# gluster v get testvol all | grep 'cluster.watermark'
cluster.watermark-hi                    10                                      
cluster.watermark-low                   75   

Expected results:

This should either be disallowed or both watermark levels(high and low) should be reset. 

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-03-08 02:05:08 EST ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

Comment 1 Vijay Bellur 2016-04-19 08:36:55 UTC
REVIEW: http://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Vijay Bellur 2016-04-20 06:52:58 UTC
REVIEW: http://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 3 Vijay Bellur 2016-04-21 08:05:43 UTC
REVIEW: http://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 4 Vijay Bellur 2016-05-24 09:31:47 UTC
REVIEW: http://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 5 Worker Ant 2017-01-03 10:42:41 UTC
REVIEW: http://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 6 Worker Ant 2017-02-09 06:46:21 UTC
REVIEW: https://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Worker Ant 2017-03-14 06:53:34 UTC
REVIEW: https://review.gluster.org/14028 (TIER: watermark check during low watermark reset) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 8 Worker Ant 2017-03-18 22:19:49 UTC
COMMIT: https://review.gluster.org/14028 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 78222bff29f27fc3b4f500ff2f7bd323c418d09e
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Apr 19 14:01:09 2016 +0530

    TIER: watermark check during low watermark reset
    
    PROBLEM: during a low watermark reset, checking of whether
    the low watermark is lower than hi watermark is not done.
    
    FIX: This patch checks if the hi watermark value is higher
    the default low watermark. Else throws an failure of the reset
    command
    
    Change-Id: I8b49090c6bccce6d45c2e8076ab766047a2a6162
    BUG: 1328342
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/14028
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 9 Shyamsundar 2017-05-30 18:34:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.