Bug 132845 - Default printer naming is different than HAL
Summary: Default printer naming is different than HAL
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-17 19:09 UTC by John (J5) Palmieri
Modified: 2013-03-13 04:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John (J5) Palmieri 2004-09-17 19:09:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
The default names for the printer queues are different between
system-config-printer and hal_lpadmin.  This causes two printer queues
to come up when configuring a printer via Kudzu on boot and when it is
detected by HAL.  system-config-printer should move to using hal's
format because it is more descriptive.  Hal's format is as follows:

<printer model>-<usb port number>

The model is converted to lowercase and whitespace is converted to dashes.

If it makes it easier the usb port number can be changed to the usb
device number.  I like port number better because if you plug the
printer into the same port each time you will get the same number.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure a printer with kudzu on boot

    

Actual Results:  you will see two configured printers queues.

Expected Results:  One printer queue.

Additional info:

Comment 1 Tim Waugh 2004-09-30 11:35:07 UTC
We don't know the port number at the time the name is generated.  You
can specify the name yourself though, using --Xadd-local --name ...


Note You need to log in before you can comment on or make changes to this bug.