Bug 1328457 - Open button doesn't work in file selection dialog
Summary: Open button doesn't work in file selection dialog
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1310542
TreeView+ depends on / blocked
 
Reported: 2016-04-19 12:39 UTC by Kamil Páral
Modified: 2016-09-20 02:47 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-04-26 16:35:23 UTC


Attachments (Terms of Use)
bug demonstration video (304.54 KB, application/ogg)
2016-04-19 12:39 UTC, Kamil Páral
no flags Details
rpm -qa (75.96 KB, text/plain)
2016-04-20 12:29 UTC, Kamil Páral
no flags Details
reproduce video (808.29 KB, application/ogg)
2016-04-25 09:08 UTC, lnie
no flags Details
running "liveusb-creator_polkit" command (910.90 KB, application/ogg)
2016-04-25 09:18 UTC, lnie
no flags Details

Description Kamil Páral 2016-04-19 12:39:57 UTC
Created attachment 1148561 [details]
bug demonstration video

Description of problem:
In the file selection dialog, if I click on Open button, it does not confirm the selection of the selected file, but instead opens the first directory in the list. I have to double click on a file to really select it. See video.

Version-Release number of selected component (if applicable):
liveusb-creator-3.92.1-1.fc23.noarch

How reproducible:
always 

Steps to Reproduce:
1. go to a dialog to choose iso manually
2. select the iso file
3. click Open button

Comment 1 satellitgo 2016-04-19 12:47:52 UTC
I also have seen this

Comment 2 Martin Bříza 2016-04-19 13:00:15 UTC
Seems like a Qt bug. Can you report GNOME and Qt versions, please?

Comment 3 Chris Murphy 2016-04-20 01:59:06 UTC
I can reproduce this.
liveusb-creator-3.92.1-1.fc23.noarch
gnome-shell-3.18.4-1.fc23.x86_64
adwaita-qt4-0.3-1.fc23.x86_64
qt5-qtbase-5.6.0-9.fc23.x86_64


The first time I click on 'Select Live ISO' I'm in /root by default, which is odd. Then I navigate to an ISO, select the ISO file, and click Open, the dialog does not close, I'm now in /home/chris/Applications. Click the up arrow to go to parent, find the ISO, select it, click Open, and again back to /home/chris/Applications. So I can't actually write a local file on Fedora 23.

Comment 4 Kamil Páral 2016-04-20 12:29 UTC
Created attachment 1149077 [details]
rpm -qa

(In reply to Martin Bříza from comment #2)
> Seems like a Qt bug. Can you report GNOME and Qt versions, please?

The file selection dialog does not look like a standard QT dialog:
http://doc.qt.io/qt-4.8/images/filedialogurls.png

It looks like something that has been home-made. Are you sure this is using a standard library widget?

Comment 5 Fedora Update System 2016-04-21 16:13:14 UTC
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 6 Fedora Update System 2016-04-21 16:14:06 UTC
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 7 Fedora Update System 2016-04-21 22:00:19 UTC
liveusb-creator-3.93.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 8 lnie 2016-04-22 07:23:18 UTC
Weird,if you start liveusb-creator by clicking the icon,the open button works fine,however,this bug will happen if you  running the command  to start the application.

Comment 9 Kamil Páral 2016-04-22 08:17:58 UTC
This is now fixed in liveusb-creator-3.93.1-1.fc24 and also the dialog looks like something not custom-made.

Lili, please verify that you're running the latest version of the tool? I started it from cmdline and it works fine for me.

Comment 10 Fedora Update System 2016-04-22 17:07:16 UTC
liveusb-creator-3.93.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 11 Fedora Update System 2016-04-24 01:25:39 UTC
liveusb-creator-3.93.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 12 lnie 2016-04-25 05:14:32 UTC
(In reply to Kamil Páral from comment #9)
> This is now fixed in liveusb-creator-3.93.1-1.fc24 and also the dialog looks
> like something not custom-made.
> 
> Lili, please verify that you're running the latest version of the tool? I
> started it from cmdline and it works fine for me.
I can still reproduce this with the 3.93.2 if I start the program by running "liveusb-creator" , which is the first command comes into my mind. Then,I found "/usr/bin/liveusb-creator_polkit" will be started together with "/usr/bin/liveusb-creator" if I click the icon,so I run"liveusb-creator_polkit" instead,and this time the open button works well:)

Comment 13 Kamil Páral 2016-04-25 08:52:55 UTC
(In reply to lnie from comment #12)
> I can still reproduce this with the 3.93.2 if I start the program by running
> "liveusb-creator" 

That is really weird, I can't reproduce it. Can you please create a video showcasing the problem? If you're using Chinese locale, can you also try English, whether it makes any difference? Thanks.

Comment 14 lnie 2016-04-25 09:08 UTC
Created attachment 1150317 [details]
reproduce video

Comment 15 lnie 2016-04-25 09:18 UTC
Created attachment 1150320 [details]
running "liveusb-creator_polkit" command

Comment 16 lnie 2016-04-25 09:36:08 UTC
[lnie@localhost ~]$ which liveusb-creator
/usr/bin/liveusb-creator
[lnie@localhost ~]$ sudo which liveusb-creator
/bin/liveusb-creator
If I start the program by running "liveusb-creator" with normal user using sudo,the open button works well,so the problem is near located now ? :)

Comment 17 Kamil Páral 2016-04-25 09:43:24 UTC
When Lili runs LUC under the root account directly, the file selection dialog has the old broken version, while running it under standard account using sudo or policykit uses the modern and working file selection dialog. Martin, any idea what can cause this? It works for me even running under root directly.

Comment 18 Fedora Update System 2016-04-26 08:14:00 UTC
liveusb-creator-3.93.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 19 Fedora Update System 2016-04-26 16:24:00 UTC
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 20 Fedora Update System 2016-04-26 16:33:37 UTC
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.