Bug 1328463 - creating a new vm from templates tab overrides template's initialization parameters
creating a new vm from templates tab overrides template's initialization para...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Tomas Jelinek
sefi litmanovich
:
: 1332489 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-19 08:57 EDT by sefi litmanovich
Modified: 2016-07-05 03:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:38:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 56382 master MERGED webadmin: vm init not loaded for new vm from template 2016-04-27 08:35 EDT

  None (edit)
Description sefi litmanovich 2016-04-19 08:57:14 EDT
Version-Release number of selected component (if applicable):
ovirt-engine-4.0.0-0.0.master.20160405102116.git3819ab7.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a template -> fill some initialization params (Initial-run sub tab in new template menu). 
2. from Templates tab in engine, choose the new template and choose New Vm from sub tab's options.

Actual results:
The new vm menu is open, template is set to the chosen template from which the new vm action was invoked, but in Initial-run sub tab all the templates initialization params are empty.

Expected results:
All initialization params that were filled on template level are inherited to the new vm menu.

Additional info:
If vm creation is invoked from the VM tab and in new vm menu the template is chosen, then it's initialization parms ARE inherited as expected.
This bug doesn't block but is related to RFE https://bugzilla.redhat.com/show_bug.cgi?id=1253710
Comment 1 Tomas Jelinek 2016-05-04 04:38:40 EDT
*** Bug 1332489 has been marked as a duplicate of this bug. ***
Comment 2 sefi litmanovich 2016-07-04 08:11:10 EDT
Verified with rhevm-4.0.2-0.2.rc1.el7ev.noarch according to steps in description. Vm inherits init params from template when invoked by template tab -> New Vm option, also by creating a new vm and specifying the template in new vm menu.
Comment 3 Sandro Bonazzola 2016-07-05 03:38:56 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.