Bug 1328490 - sadc can fwd SIGINT to init process and cause reboot
Summary: sadc can fwd SIGINT to init process and cause reboot
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sysstat   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Branislav Náter
Milan Navratil
URL:
Whiteboard:
Keywords: EasyFix, Patch, Reproducer, Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-19 13:50 UTC by Filip Krska
Modified: 2017-07-18 00:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The system is no longer rebooted unexpectedly due to SIGINT passed by "sadc" Due to a race condition, the "sadc" command sometimes passed the SIGINT signal to the init process. As a consequence, the system could be unexpectedly rebooted. This update adds a verification that the SIGINT signal is not sent to the init process. As a result, the system is no longer rebooted unexpectedly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:48:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2327 normal SHIPPED_LIVE sysstat bug fix and enhancement update 2016-11-03 13:43:59 UTC
Red Hat Knowledge Base (Solution) 2460271 None None None 2016-07-22 17:45 UTC

Description Filip Krska 2016-04-19 13:50:01 UTC
Description of problem:

Due to race condition sadc can pass SIGINT to init process and cause unexpected reboot.

Version-Release number of selected component (if applicable):

sysstat-10.1.5-7.el7.x86_64


How reproducible:

Easily


Steps to Reproduce:
1. create script

# cat /tmp/sadc_loop.sh 
while true;do
  sar 10 2 -u -P ALL -r -n DEV
done

2. execute

# /tmp/sadc_loop.sh

3. press ^C often


Actual results:

ctrl-alt-del.target is invoked soon

Expected results:

No signal is passed to init process, no reboot can be invoked.

Additional info:

Upstream issue, patch candidate:

https://github.com/sysstat/sysstat/issues/33

https://github.com/sysstat/sysstat/commit/c3de69658006af0e0e3b7746e8646b8b4cdd2860

Comment 5 Branislav Náter 2016-08-29 13:31:06 UTC
Reproduced on sysstat-10.1.5-7.el7, system was rebooted after pressing ctrl+c.
Verified on sysstat-10.1.5-11.el7. No reboot was invoked by pressing ctrl+c several times.

Comment 11 errata-xmlrpc 2016-11-04 03:48:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2327.html


Note You need to log in before you can comment on or make changes to this bug.