Bug 132851 - pcitable has wrong driver for 3ware 9000 series SATA RAID controller
pcitable has wrong driver for 3ware 9000 series SATA RAID controller
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 16:11 EDT by Dax Kelson
Modified: 2014-03-16 22:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 17:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2004-09-17 16:11:57 EDT
Description of problem:

This applies to FC2 as well as FC3 test2/rawhide (and made it so my
driver disk wouldn't work).

The current pcitable has the following 3ware entries:

0x13c1  0x1000  "3w-xxxx"
0x13c1  0x1001  "3w-xxxx"
0x13c1  0x1002  "3w-xxxx"

The last entry is wrong (using wrong driver). The device id 0x1002 is
for the 3ware 9000 series SATA RAID controller. I have one in a FC2 box.

[root@mooru root]# lspci -n
[snip]
01:03.0 Class 0104: 13c1:1002
[snip]

The last line should be:

0x13c1  0x1002  "3w-9xxx"

I have submitted a patch to the pci.ids maintainer as well.

Software version:

hwdata-0.130-1.noarch.rpm
Comment 1 Bill Nottingham 2004-09-17 16:20:37 EDT
Is this a change from the 2.4 kernel?
Comment 2 Dax Kelson 2004-09-17 16:32:08 EDT
I don't understand the question. How does the kernel version relate?

The card is brand new, I don't why the wrong entry was in there in the
first place (maybe an assumption that all 3ware cards --including
unreleased ones-- will use the 3w-xxxx driver??).

The 9000 series cards were released this summer and the driver
(3w-9xxx .. note the '9') was accepted by Linus around the 2.6.7
timeframe.

Comment 3 Bill Nottingham 2004-09-17 17:20:35 EDT
That was the question, whether there was a 2.4 3w-9xxx driver, or if
it was driven by 3w-xxxx under 2.4.

In any case, fixed, will be in future builds.
Comment 4 Dax Kelson 2004-09-17 17:41:08 EDT
I checked the 3ware website and they have a 2.4 driver for it, and it
has an identical name as the 2.6 driver '3w-9xxx'.

Source code is here:
http://www.3ware.com/download/Escalade9000Series/9.0.2/3w-9xxx2.4.tgz

(I looked inside the tarball to completely verify)

So it was never driven by the 3w-xxxx driver.
Comment 5 Michael Benz 2004-09-22 20:11:57 EDT
Thanks for handling this, I have been trying to get this updated for 
a while with little luck. Originally the mapping was entered wrong 
since it was added prior to the new product shipping which required a 
new driver hence the module name being different.

Note You need to log in before you can comment on or make changes to this bug.