Bug 132860 - Korean alphabet is removed to consonants and vowels'(Jamo) unit
Korean alphabet is removed to consonants and vowels'(Jamo) unit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-17 22:46 EDT by sangu
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 11:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-09-17 22:46:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.4.0

Description of problem:
Input Korean alphabet(hangul). Input work well.

Remove Korean alphabet. 
 1. Good :  With "Del" Key 
 -   Removed Korean alhabet(hangul) to Charater unit.
 2. Bad  :  With "Backspace" key
 -  Removed Korean alphabet(hangul) to Jamo unit. 
 error message in gedit.

(gedit:4069): GtkSourceView-CRITICAL **: file gtksourceundomanager.c:
line 617 (gtk_source_undo_manager_insert_text_handler): assertion
`strlen (text) == (guint)length' failed

This problem happens  in  all gtk2 program's textarea.
But No problem in gnome-terminal(2.7.3), evolution mail editor(1.5.94).

Version-Release number of selected component (if applicable):
gtk2-2.4.9-8

How reproducible:
Always

Steps to Reproduce:
1. remove Korea alphabet with "Backspace" key.
2.
3.
    

Additional info:

locale ko_KR.UTF-8

pango 1.5.2-3, xorg-x11-6.8.0-4.
Comment 1 sangu 2004-09-17 23:00:15 EDT
This problem happens from gtk2 2.4.9-7.
But this problem doesn't happen in gtk2 2.4.9-6.
Comment 2 Matthias Clasen 2004-09-20 11:27:40 EDT
The problem is actually in gtksourceview. A fixed gtksourceview-1.1.0-3
is stuck in fc3-hold.
Comment 3 sangu 2004-09-20 12:10:35 EDT
 Matthias Clasen : Ok, But to remove Korean alphabet(hangul) with
backspace key is strange (in gtk2-2.4.9-8, 2.4.9-7)

http://hellocity.net/~sangu/files/fedora/Bug/Strange%20Remove.png

And this problem doesn't happen in evolution mail editor,
gnome-terminal, mozilla.



Comment 4 Matthias Clasen 2004-10-15 11:57:11 EDT
The crash in gtksourceview is fixed now. The question if the backspace behaviour
is right for all languages is tracked in other bugs, so I'm closing this one.

Note You need to log in before you can comment on or make changes to this bug.