Bug 1328673 - [GSS](6.4.z) In EAP, is it able to record TERM signal in server.log?
Summary: [GSS](6.4.z) In EAP, is it able to record TERM signal in server.log?
Keywords:
Status: CLOSED DUPLICATE of bug 1116086
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Fedor Gavrilov
QA Contact: Nikoleta Hlavickova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-20 03:04 UTC by xuzhan
Modified: 2019-10-10 11:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-26 04:37:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 58782 None None None 2017-03-02 22:51:49 UTC
Red Hat One Jira Issue Tracker WFCORE-1498 Major Resolved Different shutdown messages depending on reason for shutdown 2017-06-23 03:24:54 UTC

Description xuzhan 2016-04-20 03:04:15 UTC
Description of problem:
When EAP 6.x running in service/non-service mode on Linux, if use "kill -15 <EAP_PID>" or send TERM signal by system[1] to shutdown EAP, there is no clear message in server.log to let user know the shutdown reason.

[1]http://man7.org/linux/man-pages/man5/systemd.service.5.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
For example, server.log is able to record that EAP was shutdown by signal TERM.
After that user can narrow down the issue quickly.

Additional info:
Please let us know if it is able to implement in next release?

Comment 1 James Perkins 2016-04-20 15:03:44 UTC
What specific OS and JDK are being used? I believe in most cases the hotspot VM will honor shutdown hooks for SIGTERM. There is no guarantee that shutdown hooks will run though. There's likely not much we can do about this.

Comment 3 Fedor Gavrilov 2016-04-21 09:33:36 UTC
The description of problem states that there is no clear indication of shutdown reason, not just the fact that EAP 6 was shut down by request. 
So, to re-iterate, what do we want in the logs in first place? Indication that server was shutdown by exactly SIGTERM signal or just "Server shutdown has been requested." as it is now in EAP7, as Brian mentioned?

Comment 4 dereed 2016-04-21 21:37:00 UTC
> what do we want in the logs in first place?

Details on what triggered the shutdown.  
Signal (and which signal), explicit shutdown command, System.exit() call, etc.

Comment 5 dereed 2016-04-21 21:39:06 UTC
Note that in EAP 5 there are different logs for each of those triggers.

They're not explicitly stated (you have to know what logs correspond to what trigger), and the specific signal is not logged.  But EAP 6 does not have any indication of what triggered a shutdown.

Comment 15 Brad Maxwell 2017-02-26 04:37:42 UTC

*** This bug has been marked as a duplicate of bug 1116086 ***


Note You need to log in before you can comment on or make changes to this bug.