Bug 1328677 - [RFE] PackageKit should respect dnf versionlock
Summary: [RFE] PackageKit should respect dnf versionlock
Keywords:
Status: CLOSED DUPLICATE of bug 1256108
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-20 03:17 UTC by Nick Coghlan
Modified: 2016-04-20 03:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1849567 (view as bug list)
Environment:
Last Closed: 2016-04-20 03:50:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Nick Coghlan 2016-04-20 03:17:19 UTC
Description of problem:

I have a few packages pinned to particular versions with the dnf versionlock plugin, but PackageKit still wants to upgrade them

Version-Release number of selected component (if applicable):

PackageKit-1.0.11-1.fc23.x86_64

How reproducible:

Always

Steps to Reproduce:
1. dnf install 'dnf-command(versionlock)'
2. dnf versionlock add <some component with updates available>
3. wait for next PackageKit pending update notification

Actual results:

dnf considers the pinned components up to date, PackageKit doesn't and wants to update them

Expected results:

Neither dnf nor PackageKit tries to upgrade the pinned components

Additional info:

This shouldn't require merged metadata caches, just PackageKit being aware of the DNF plugin's list of pinned packages:

$ cat /etc/dnf/plugins/versionlock.list 

# Added locks on Tue Apr 19 23:19:06 2016
docker-1:1.10.2-9.git0f5ac89.fc23.*
docker-selinux-1:1.10.2-9.git0f5ac89.fc23.*
docker-v1.10-migrator-1:1.10.2-9.git0f5ac89.fc23.*
docker-forward-journald-1:1.10.2-9.git0f5ac89.fc23.*

Plugin docs: http://dnf-plugins-extras.readthedocs.org/en/latest/versionlock.html

Comment 1 Rex Dieter 2016-04-20 03:50:34 UTC

*** This bug has been marked as a duplicate of bug 1256108 ***


Note You need to log in before you can comment on or make changes to this bug.