Bug 1328789 - do not leave partially downloaded files on disk
Summary: do not leave partially downloaded files on disk
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator   
(Show other bugs)
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1310542
TreeView+ depends on / blocked
 
Reported: 2016-04-20 09:52 UTC by Kamil Páral
Modified: 2016-09-20 02:47 UTC (History)
4 users (show)

Fixed In Version: liveusb-creator-3.93.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 16:35:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kamil Páral 2016-04-20 09:52:54 UTC
Description of problem:
If I start downloading and image and hit cancel, the partial file is kept on disk, but nothing implies it is just a partial file:

$ ls -lh ~/Fedora-Live-Workstation-x86_64-23-10.iso 
-rw-r--r--. 1 root root 199M Apr 20 11:49 /home/kparal/Fedora-Live-Workstation-x86_64-23-10.iso

Please either remove the partial file when the download is canceled, or, in case you can resume the download, at least add ".part" suffix to the file until it is complete.

Version-Release number of selected component (if applicable):
liveusb-creator-3.92.1-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1. start downloading an image
2. hit cancel
3. look into ~ to see a partial file that looks like a proper full file

Comment 1 Fedora Update System 2016-04-21 16:13:03 UTC
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 2 Fedora Update System 2016-04-21 16:14:00 UTC
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 3 Fedora Update System 2016-04-21 22:00:07 UTC
liveusb-creator-3.93.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 4 Kamil Páral 2016-04-22 07:39:44 UTC
fixed with liveusb-creator-3.93.1-1.fc24

Comment 5 Fedora Update System 2016-04-22 17:07:10 UTC
liveusb-creator-3.93.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 6 Fedora Update System 2016-04-24 01:25:33 UTC
liveusb-creator-3.93.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 7 Fedora Update System 2016-04-26 08:13:54 UTC
liveusb-creator-3.93.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 8 Fedora Update System 2016-04-26 16:23:54 UTC
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c

Comment 9 Fedora Update System 2016-04-26 16:33:28 UTC
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.