Bug 1328921 - Importing HE with VNC device attached creates corrupted VM in the database
Summary: Importing HE with VNC device attached creates corrupted VM in the database
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 3.6.5.1
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-3.6.7
: 3.6.7.3
Assignee: Roman Mohr
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On: 1339305 1339306
Blocks: 1326810
TreeView+ depends on / blocked
 
Reported: 2016-04-20 15:21 UTC by Roman Mohr
Modified: 2017-05-11 09:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The graphics device was not imported when the hosted engine VM was imported into the engine. Furhter the VM display type of the imported VM was always set to qxl. Consequence: Because of the, when trying to manipulate the hosted engine VM through the REST API the validation failed. When manipulating it through the GUI by accident the validation passed. Fix: Import the right graphics device and set the right display type. Further update the VM definition for already imported hosted engine VMs to represent a valid VM. Result: Manipulation works through REST and GUI. It is also important to not that only after the first OVF flush after the engine upgrade on an already imported hosted engine VM, the hosted engine agent on the host will get the correct display values. Further he-agent needs to up to date to start the VM with the right parameters when reading the vm configuration from the OVF store. More in bug https://bugzilla.redhat.com/show_bug.cgi?id=1339305 about that.
Clone Of:
Environment:
Last Closed: 2016-07-04 12:29:19 UTC
oVirt Team: SLA
rule-engine: ovirt-3.6.z+
mgoldboi: planning_ack+
rgolan: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1343593 0 unspecified CLOSED after hosted-engine --upgrade-appliance action is done, HE VM still runs with old disk 2021-02-22 00:41:40 UTC
oVirt gerrit 57298 0 ovirt-engine-3.6 MERGED core: Import graphics devices from hosted engine VM 2016-06-01 08:58:46 UTC
oVirt gerrit 57906 0 master MERGED Make video device explicit 2016-05-25 07:20:00 UTC
oVirt gerrit 58063 0 master MERGED core: Import graphics devices from externally managed VMs 2016-05-30 09:42:41 UTC
oVirt gerrit 58255 0 ovirt-engine-4.0 MERGED core: Import graphics devices from externally managed VMs 2016-06-01 08:57:51 UTC
oVirt gerrit 58313 0 ovirt-engine-3.6.7 MERGED core: Import graphics devices from hosted engine VM 2016-06-05 09:00:49 UTC

Internal Links: 1343593

Description Roman Mohr 2016-04-20 15:21:15 UTC
Description of problem:

On 3.6 when installing the hosted engine with a VNC device the import in the engine creates a VM which has no graphics device attached:

 * VNC device is not there
 * Graphics column shows VNC
 * Edit VM dialogue shows SPICE
 * Editing the VM is not possible because no graphics device is there

On 4.0 you always end up with a SPICE device no matter what you selected during "hosted-engine --deploy"


Version-Release number of selected component (if applicable):
3.6 and higher

How reproducible:

During "hosted-engine --deploy" select the grapics device VNC.

Steps to Reproduce:
1. hosted-engine --deploy with VNC device
2. after the setup completed log into the hosted engine and add a master domain
3. after import of the hosted engine domain is done check the VMs devices

Actual results:

No graphics device there and editing the VM is not possible because of this.

Expected results:
VNC should be there.

Additional info:

Selecting SPICE gives the expected result on 3.6 and 4.0

Comment 1 Roman Mohr 2016-06-01 14:54:25 UTC
Moving back to post since there will be another 3.6.7 build I can catch.

Comment 2 sefi litmanovich 2016-06-09 11:48:04 UTC
Verified according to description with:
HOST:
vdsm-4.17.31-0.el7ev.noarch
ovirt-hosted-engine-ha-1.3.5.7-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.7.2-1.el7ev.noarch
ENGINE:
rhevm-3.6.7.3-0.1.el6.noarch

after vm import to engine edit vm shows VNC/cirrus, so does vdsm and vm.conf.


Note You need to log in before you can comment on or make changes to this bug.