Bug 132894 - creating an arc with arc tool causes X server infinite loop
creating an arc with arc tool causes X server infinite loop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dia (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 17:44 EDT by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 05:15:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-09-18 17:44:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
Create an empty diagram in dia.  Select the arc tool, drop an arc into
the diagram.  This instantly drops the X server into a loop consuming
100% of CPU, which is clearly being caused by dia doing something silly.

This problem only occurs with the x86_64 build of dia; the i386
version is fine.

Version-Release number of selected component (if applicable):
0.92.2

How reproducible:
Always

Steps to Reproduce:
1. Create an empty diagram in dia.
2. Select the arc tool, drop an arc into the diagram.
3. Pow!
    

Actual Results:  The X server goes into an infinite loop, requiring me
to ssh in from another machine to kill dia.

Additional info:
Comment 1 Bill Nottingham 2004-09-20 12:02:54 EDT
While dia should be fixed too, the X server should handle this, I'd think.
Comment 2 Bryan O'Sullivan 2004-09-20 12:18:08 EDT
I'm not sure the server is actually inflooping per se.  I think it's
more likely to be the equivalent of a DoS attack, where dia gets weird
and slams the server with so many requests that the server can't do
anything.

If the server itself were at fault, killing dia would be unlikely to
revive it, in my experience.
Comment 3 Mike A. Harris 2004-09-20 16:59:04 EDT
Reassigning to "dia" component for package maintainer to confirm
in gdb, that this is not a case of dia DoS flooding the X server
with requests.

Once confirmed beyond any doubt that this is a legitimate X server
bug, feel free to add comment to bug summarizing troubleshooting
conclusions of dia, and the X Devel team will investigate.
Comment 4 Bryan O'Sullivan 2004-09-20 17:01:04 EDT
By the way, I have a report from a friend that this "works for him" in
whatever version of dia ships with FC3T1 on x86_64, so it might be
worth checking that first.  I don't have time to update to FC3T1 or
Rawhide myself, so I can't verify this.
Comment 5 Caolan McNamara 2005-03-04 05:15:54 EST
This is not doing anything strange for me with 0.94-6 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.