Bug 132905 - Why do I get last message repeated 25 times ?
Why do I get last message repeated 25 times ?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-19 01:14 EDT by Bob Gustafson
Modified: 2013-07-02 19:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 01:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-09-19 01:14:33 EDT
Description of problem:

My /var/log/messages file has lots of 'last message repeated' lines.
This seems excessive. Not much information is provided about the
context or reason for the repeated message.

Version-Release number of selected component (if applicable):

 up2date

How reproducible:

  Seems to be repeated quite a bit :-;

Steps to Reproduce:

1. tail -100 /var/log/messages | more
2. look for 'last message repeated' lines
3.
  
Actual results:

Sep 18 23:30:01 hoho2 crond(pam_unix)[5140]: session closed for user root
Sep 18 23:30:02 hoho2 pam_timestamp_check: pam_timestamp: `/' owner
UID != 0
Sep 18 23:30:33 hoho2 last message repeated 13 times
Sep 18 23:31:37 hoho2 last message repeated 25 times
Sep 18 23:32:38 hoho2 last message repeated 25 times
Sep 18 23:33:42 hoho2 last message repeated 25 times
Sep 18 23:34:43 hoho2 last message repeated 25 times
Sep 18 23:34:58 hoho2 last message repeated 6 times
Sep 18 23:35:01 hoho2 crond(pam_unix)[5266]: session opened for user
mailman by
(uid=0)
Sep 18 23:35:01 hoho2 crond(pam_unix)[5267]: session opened for user
root by (uid=0)
Sep 18 23:35:02 hoho2 crond(pam_unix)[5266]: session closed for user
mailman
Sep 18 23:35:02 hoho2 crond(pam_unix)[5267]: session closed for user root
Sep 18 23:35:02 hoho2 pam_timestamp_check: pam_timestamp: `/' owner
UID != 0
Sep 18 23:35:33 hoho2 last message repeated 13 times
Sep 18 23:36:37 hoho2 last message repeated 25 times
Sep 18 23:37:38 hoho2 last message repeated 25 times
Sep 18 23:38:42 hoho2 last message repeated 25 times
Sep 18 23:39:43 hoho2 last message repeated 25 times
Sep 18 23:39:58 hoho2 last message repeated 6 times
Sep 18 23:40:01 hoho2 crond(pam_unix)[5391]: session opened for user
root by (ui--More--

Expected results:

  Either eliminate the reason for the repeated messeage, or provide
more explanation.

Additional info:

[root@hoho2 log]# date
Sun Sep 19 00:13:29 CDT 2004
[root@hoho2 log]# cat /proc/version
Linux version 2.6.8-1.541smp (bhcompile@porky.build.redhat.com) (gcc
version 3.4.1 20040831 (Red Hat 3.4.1-10)) #1 SMP Wed Sep 1 18:15:33
EDT 2004
[root@hoho2 log]#
[root@hoho2 log]# yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3515/3515
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
No Packages marked for Update/Obsoletion
[root@hoho2 log]

Selinux enabled targeted and Enforcing.
[root@hoho2 log]# getenforce
Enforcing
[root@hoho2 log]#
Comment 1 Bill Nottingham 2004-09-20 12:13:35 EDT
What 'last message repeated XX' means is that whatever message
appeared *before* this is what's repated.

From the looks of it, your permissions/ownership on / is wrong.
Comment 2 Bob Gustafson 2004-09-23 01:31:58 EDT
I changed the ownership of / from user1:user1 to root:root around 07:53

[root@hoho2 ~]# ls -ld /
drwxr-xr-x  27 root root 4096 Sep 22 07:53 /
[root@hoho2 ~]#

tail -1000 /var/log/messages | grep "last message"
...
...
Sep 21 15:06:38 hoho2 last message repeated 25 times
Sep 21 15:06:54 hoho2 last message repeated 7 times
Sep 22 07:54:10 hoho2 last message repeated 15 times
[root@hoho2 ~]# date
Thu Sep 23 00:31:19 CDT 2004

=== Looks like it nailed it - thanks much

Worksforme
Comment 3 whitecurve 2005-12-03 11:17:56 EST
Can anyone suggest an alternative reason for the error messages?

Like the initial reporter of this issue I get hundreds of these messages in my Log.

Dec  3 15:25:01 host_xyz crond(pam_unix)[26309]: session closed for user mailman
Dec  3 15:30:01 host_xyz crond(pam_unix)[26440]: session opened for user mailman
by (uid=0)

I have also checked the permissions of / and it looks ok.

[root@xyxhost ~]# ls -ld /
drwxr-xr-x  24 root root 4096 Dec  1 09:52 /

can anyone help?

Note You need to log in before you can comment on or make changes to this bug.