Bug 1329209 - ipa-nis-manage enable: change service name from 'portmap' to 'rpcbind'
Summary: ipa-nis-manage enable: change service name from 'portmap' to 'rpcbind'
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-21 12:19 UTC by Sudhir Menon
Modified: 2016-11-04 05:53 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:53:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-04-21 12:19:24 UTC
Description of problem: Change service name from portmap to rpcbind displayed on console.

Version-Release number of selected component (if applicable):

How reproducible:Always


Steps to Reproduce:
1. ipa-server-install
2. Enable nis plugin on the ipa-server using the below command.

#ipa-nis-manage enable -y /tmp/paswd.txt 

3. Now check the message displayed on the console.

Actual results:

[root@host2 ~]# ipa-nis-manage enable -y /tmp/paswd.txt
Enabling plugin
This setting will not take effect until you restart Directory Server.
The portmap service may need to be started.

Expected results:
portmap service is renamed as rpcbind hence the service name should be updated.

i.e 'The rpcbind service may need to be started'

Additional info:

Comment 2 Petr Vobornik 2016-04-28 12:38:23 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5857

Comment 3 Martin Bašti 2016-05-10 14:30:59 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/bede6c282e6d321c348dc2d33c6d1f9c14093a57

Comment 5 Sudhir Menon 2016-07-18 10:11:48 UTC
Fix is seen.
Verified using ipa-server-4.4.0-2.1.el7.x86_64

[root@server ~]# ipa-nis-manage enable -y /tmp/paswd.txt
Enabling plugin
This setting will not take effect until you restart Directory Server.
The rpcbind service may need to be started.

Comment 7 errata-xmlrpc 2016-11-04 05:53:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.