Bug 1329275 - ipa-nis-manage command should include status option
Summary: ipa-nis-manage command should include status option
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-21 13:43 UTC by Sudhir Menon
Modified: 2016-11-04 05:53 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:53:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-04-21 13:43:29 UTC
Description of problem: ipa-nis-manage command should include status option.

Version-Release number of selected component (if applicable):

How reproducible:Always

Steps to Reproduce:
1. Install ipa server
2. Enable compat plugin and check status

#ipa-compat-manage enable
#ipa-compat-manage status -y passwd.txt
Plugin Disabled

3. Enable nis plugin 
#ipa-nis-manage enable
#ipa-nis-manage status -y passwd.txt
Unrecognized action [status]

Actual results:
#ipa-nis-manage status -y passwd.txt
Unrecognized action [status]

Expected results: Should include 'status' option for ipa-nis-manage command
which displays the status whether the plugin is enabled or not if we need to check it explicitly from command line.

Additional info:

Comment 2 Petr Vobornik 2016-04-28 12:34:18 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5856

Comment 3 Martin Bašti 2016-05-24 08:18:17 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/9079d2f9c8a948702f1234e8337d8bf0dc291756

Comment 5 Sudhir Menon 2016-07-18 10:13:39 UTC
Fix is seen.
Verified using ipa-server-4.4.0-2.1.el7.x86_64


[root@server ~]# ipa-nis-manage status
Directory Manager password: 
Plugin is enabled

[root@server ~]# ipa-nis-manage disable
Directory Manager password: 

This setting will not take effect until you restart Directory Server.
[root@server ~]# ipa-nis-manage status
Directory Manager password: 
Plugin is not enabled

Comment 7 errata-xmlrpc 2016-11-04 05:53:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.