Bug 13293 - lockd and automounter fail during shutdown - dfct18675
Summary: lockd and automounter fail during shutdown - dfct18675
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2000-06-30 20:36 UTC by Becky Miller
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-27 20:46:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Becky Miller 2000-06-30 20:36:01 UTC
At system boot lockd and automounter are [ok] but [fail] when shutting 
down.  This happens on all Dell PowerEdge servers.

Comment 1 Henri Schlereth 2000-07-03 06:24:03 UTC
I am also seeing this(lockd) on my built-from-scratch boxes, so it isnt just a
Dell boxen prob.

Comment 2 Michael Redinger 2000-07-05 13:34:50 UTC
The nfs lockd part is a duplicate of #12316.

As of automounter:

At first boot after installation I do get the following messages:

insmod: insmod: a module named autofs already exists
insmod: insmod autofs failed

The first of these two messages is only shown at the fist boot.

The message is shown right after "Initializing random number generator". So I do
suppose that this happens in S25netfs (when in runlevel 3).

At shutdown, the exact message is:

Stopping automounter [OK]
Stopping automounter (attempt 2) /usr/sbin/automount: no process killed

I did also upgrade to the latest initscripts (that where published when updating
XFree86 in beta2). Same result.

Comment 3 Nalin Dahyabhai 2000-07-06 13:56:05 UTC
Shutting down autofs is always tricky, especially when filesystems controlled
by autofs are busy.  This should be improved somewhat in the current release,
though the busy filesystem problem remains not completely solved.

Comment 4 Bill Nottingham 2000-07-06 21:46:41 UTC
changed component to autofs.

Comment 5 Kurt Ludwig 2000-07-21 18:12:18 UTC
on AXP in beta 3, on boot it throws simmilar messages about not being able to 
insert the module into the kernel. But when you log in, it is running and yes 
the file systems are auto-mountable when they are called.

Kurt Ludwig

Comment 6 Bill Nottingham 2000-07-25 19:27:50 UTC
I can't reproduce this in beta4. lockd shutdown works

Comment 7 Becky Miller 2000-07-27 20:46:41 UTC
This is fixed in Beta 5.  Thanks!

Comment 8 Nalin Dahyabhai 2000-07-31 21:45:27 UTC
Okay, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.