Bug 1329368 - libsoup is built without GSSAPI support
Summary: libsoup is built without GSSAPI support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsoup
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F24BetaFreezeException 1329371
TreeView+ depends on / blocked
 
Reported: 2016-04-21 18:35 UTC by Alexander Bokovoy
Modified: 2016-04-23 23:43 UTC (History)
7 users (show)

Fixed In Version: libsoup-2.54.0.1-3.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:43:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Alexander Bokovoy 2016-04-21 18:35:31 UTC
libsoup 2.53.92+ supports GSSAPI authentication. However, libsoup spec in Fedora 24 and rawhide does not include BuildRequires: krb5-devel and GSSAPI support is not enabled.

This prevents building webkitgtk with GSSAPI support enabled and Epiphany.

Finally, this makes impossible to showcase GNOME 3.20 single sign-on support.

Comment 1 Fedora Blocker Bugs Application 2016-04-21 19:13:11 UTC
Proposed as a Freeze Exception for 24-beta by Fedora user abbra using the blocker tracking app because:

 libsoup was built in Fedora 24 without GSSAPI authentication support. This prevents us to showcase GNOME 3.20 single sign-on effort.

The risk of updating libsoup is confined to libsoup and webkitgtk4 which needs to be rebuilt as well (bug  1329371) to allow Epiphany and GNOME Online Accounts to use single sign-on features.

Comment 2 Michael Catanzaro 2016-04-21 19:23:06 UTC
(In reply to Alexander Bokovoy from comment #0)
> libsoup 2.53.92+ supports GSSAPI authentication. However, libsoup spec in
> Fedora 24 and rawhide does not include BuildRequires: krb5-devel and GSSAPI
> support is not enabled.

libsoup's upstream configure script should be modified to produce an error if this dependency is missing but --disable-gssapi or something along those lines is not passed. This automagic dependency crap just results in features going missing from distros. Otherwise this is gonna be a Fedora-only thing, because only Fedora knows to add the magic BuildRequires.

Comment 3 Alexander Bokovoy 2016-04-21 19:36:02 UTC
Upstream configure.ac has this:

dnl **********************
dnl *** GSSAPI support ***
dnl **********************
AC_ARG_WITH(gssapi,
	    AS_HELP_STRING([--with-gssapi],
	    [Build with GSSAPI support [default=auto]]))

and it also has error checking for --with-gssapi=yes:
        if test "$with_gssapi" == "yes"; then
	    AC_MSG_ERROR([GSSAPI support requested but failed to found krb5-config. Try to set KRB5_CONFIG.])
	fi

I'm not sure if changing from auto to yes would make sense as a default upstream.

Comment 4 Nathaniel McCallum 2016-04-21 20:36:56 UTC
I can confirm that rebuilding libsoup with krb5-devel installed makes GSSAPI work for epiphany.

Comment 5 Michael Catanzaro 2016-04-21 22:50:57 UTC
(In reply to Alexander Bokovoy from comment #3)
> I'm not sure if changing from auto to yes would make sense as a default
> upstream.

I think it would; distros would all prefer one failed build than to accidentally miss this feature. Plus it seems to be the only automagic dependency currently in the configure script. Anyway, Dan is CCed, he can change it if he wants.

Comment 6 Fedora Update System 2016-04-22 08:26:04 UTC
libsoup-2.54.0.1-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd7c1300dc

Comment 7 Adam Williamson 2016-04-22 18:01:12 UTC
If you just want to do a build against that libsoup, you can submit a buildroot override. You don't need a freeze exception. (Ideally make sure the rebuilt webkitgtk goes into the same update as libsoup, once it's built).

https://bodhi.fedoraproject.org/overrides/new

On its merits I'm -1 FE on this, I don't see a reason it needs to break the freeze; it's not really something that'd be useful from a live image, for e.g.

Comment 8 Nathaniel McCallum 2016-04-22 18:03:28 UTC
I don't care about breaking the freeze. As long as we ship in F24, I'm happy.

Comment 9 Nathaniel McCallum 2016-04-22 18:04:46 UTC
Also, we don't need to rebuild webkitgtk4.

Comment 10 Adam Williamson 2016-04-22 18:07:05 UTC
the Beta freeze applies only to...beta. Without an FE the libsoup in the Beta images would not have GSSAPI support, but anyone who installs Beta would get it on their first system update. If there is some reason it's important for the support to be there on first boot or in the live images, please say so.

The *Final* release would certainly include the fixed libsoup, so long as it's pushed stable in the usual way between Beta release and Final freeze.

Comment 11 Alexander Bokovoy 2016-04-22 19:08:33 UTC
Adam,

we (IPA and Desktop teams) wanted to publicize in Fedora Magazine and showcase Fedora 24 beta with GNOME 3.20 single sign-on features. Not allowing to get libsoup into the Beta images makes the Fedora Magazine article effort fruitless.

If Fedora are not interested in that, fine. I have better things to spent my time on now that Badlock activity ended.

Comment 12 Adam Williamson 2016-04-22 19:17:54 UTC
You don't have to be angry about it, we just can't rubber-stamp proposals with no clear justification, or else we might as well not have the FE process or freezes at all.

Does the update actually have to go into the images in order to write an article about it? Wouldn't it be fine to just have a step to update the system after doing the install? Or does the updated libsoup have to be present during install or on first boot?

Comment 13 Alexander Bokovoy 2016-04-22 19:24:23 UTC
I don't see any benefit of targeting Beta if you'd need to update packages. The article then can be written and published at any time when packages come to the install.

Given that you can enroll to IPA or other enterprise environment on first boot, lack of proper libsoup version prevents you from configuring automatically GNOME online accounts against your services, for example.

In other words, it is, of course, my problem that I was unable to spot this issue earlier than the Beta freeze, but I hope we can at least have the package in the Beta to unlock some marketing potential around first half of May.

Comment 14 Alexander Bokovoy 2016-04-22 19:26:28 UTC
Also, see https://plus.google.com/+AlexanderBokovoy/posts/LggNiqH4AP2 for the reasons of the Beta targetting. Unfortunately, shortly after that discussion Badlock activities took over my priorities.

Comment 15 Adam Williamson 2016-04-22 19:29:18 UTC
sure, that's fine. It's not about blaming anyone for anything, it's simply a case of making sure we only break the freeze when there's actually a good reason to.

with that explanation, +1 FE.

Comment 16 Dennis Gilmore 2016-04-22 19:31:50 UTC
+1 FE

Comment 17 Kevin Fenzi 2016-04-22 19:32:58 UTC
+1 FE

Comment 18 Adam Williamson 2016-04-22 19:40:18 UTC
ok, that's +3, setting accepted.

Comment 19 Fedora Update System 2016-04-23 21:23:31 UTC
libsoup-2.54.0.1-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd7c1300dc

Comment 20 Fedora Update System 2016-04-23 23:43:00 UTC
libsoup-2.54.0.1-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.