Bug 132945 - up2date error with Traceback message
Summary: up2date error with Traceback message
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-20 06:40 UTC by pillboy
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:18:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for workaround (662 bytes, patch)
2004-10-26 20:59 UTC, cg
no flags Details | Diff

Description pillboy 2004-09-20 06:40:26 UTC
Description of problem:
I had get an error message while I run up2date
================================================================
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 752, in 
onProfilePagePrepare
    self.hardware = hardware.Hardware()
  File "/usr/share/rhn/up2date_client/hardware.py", line 531, in 
Hardware
    ret = read_network()
  File "/usr/share/rhn/up2date_client/hardware.py", line 359, in 
read_network
    hostname, ipaddr = findHostByRoute()
  File "/usr/share/rhn/up2date_client/hardware.py", line 328, in 
findHostByRoute
    (server, port) = string.split(server_port, ':')
  File "/usr/lib/python2.2/string.py", line 122, in split
    return s.split(sep, maxsplit)
AttributeError: 'NoneType' object has no attribute 'split'
================================================================
I cannot register any profile to use up2date. Does anyone know how to 
solve it? Many thanks!

Version-Release number of selected component (if applicable):
up2date-4.2.33-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Suzanne Hillman 2004-09-30 21:13:33 UTC
If you have not already, you would be wise to contact support, at
800-REDHAT1, or http://www.redhat.com/support, about this matter. You
will need your up-to-date entitlement information for this purpose.

Comment 2 cg 2004-10-26 20:59:33 UTC
Created attachment 105815 [details]
patch for workaround

workaround patch.  see bug comments

Comment 3 cg 2004-10-26 21:00:37 UTC
sorry, this comment was intended to precede the above patch...

i had the same problem.  apparently it has to do with the
'self.hardware' object not containing a field named 'class' for every
'hw' in the iteration (please excuse my lack of python-oriented
terminology -- i'd never seen python before this).

a *work-around* is as follows (see one-liner diff in attachment [well,
essentially one-liner, python doesn't diff well with all that
essential formatting...]), simply check to see whether the current
'hw' object in the loop iteration has a 'class' key.

this DOES NOT fix whatever is causing the self.hardware object to
contain entries without the 'class' field.  for that, i unfortunately
have no suggestion or idea.

Comment 4 RHEL Product and Program Management 2007-10-19 19:18:06 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.