Bug 1329483 - Current stable kdepimlibs (4.14.10-12) requires newer kdelibs (>= 4.14.19)
Summary: Current stable kdepimlibs (4.14.10-12) requires newer kdelibs (>= 4.14.19)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F24BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-22 04:11 UTC by Adam Williamson
Modified: 2017-07-31 18:47 UTC (History)
13 users (show)

Fixed In Version: kdelibs-4.14.19-3.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:43:31 UTC


Attachments (Terms of Use)

Description Adam Williamson 2016-04-22 04:11:41 UTC
https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c11cc2120 was given a karma threshold of just +1, and was pushed stable due to that threshold yesterday. However, that kdepimlibs requires kdelibs4 >= 4.14.19 , which is not in stable. The update that provides kdelibs4 4.14.19 is still in testing:

https://bodhi.fedoraproject.org/updates/FEDORA-2016-f1721e7f7d

thus dependencies in F24 stable are currently broken, and upgrading from F23 to F24 fails due to this issue.

Proposing as an F24 Beta 0-day blocker: "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed.", affecting the KDE package set.

Comment 1 Adam Williamson 2016-04-22 04:13:08 UTC
this also prevents compose of the KDE live image, in fact, so proposing it as a regular blocker, not just a 0-day blocker.

Comment 2 Fedora Update System 2016-04-22 10:49:40 UTC
PyQt4-4.11.4-14.fc24 kde-baseapps-16.04.0-3.fc24 kde-runtime-16.04.0-3.fc24 kde-workspace-4.11.22-13.fc24 kdegraphics-mobipocket-16.04.0-2.fc24 kdegraphics-strigi-analyzer-16.04.0-2.fc24 kdelibs-4.14.19-3.fc24 kdepimlibs-4.14.10-13.fc24 kolourpaint-16.04.0-2.fc24 ksaneplugin-16.04.0-2.fc24 libkscreen-1.0.5-9.fc24 okular-16.04.0-2.fc24 phonon-4.8.3-12.fc24 plasma-breeze-5.6.3-2.fc24 plasma-oxygen-5.6.3-2.fc24 qca-2.1.1-6.fc24 qscintilla-2.9.2-3.fc24 qt-4.8.7-17.fc24 svgpart-16.04.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f1721e7f7d

Comment 3 Dennis Gilmore 2016-04-22 14:18:10 UTC
+1 blocker

Comment 4 Jon Disnard 2016-04-22 14:25:05 UTC
Agree. +1 blocker

Comment 5 Paul Whalen 2016-04-22 14:59:21 UTC
+1 blocker

Comment 6 Kalev Lember 2016-04-22 15:07:22 UTC
+1 blocker

Comment 7 Tim Flink 2016-04-22 15:08:01 UTC
+1 blocker, making +5, moving to accepted

Comment 8 Mike Ruckman 2016-04-22 16:39:22 UTC
+1 belated blocker vote.

Comment 9 Fedora Update System 2016-04-23 23:43:14 UTC
PyQt4-4.11.4-14.fc24, kde-baseapps-16.04.0-3.fc24, kde-runtime-16.04.0-3.fc24, kde-workspace-4.11.22-13.fc24, kdegraphics-mobipocket-16.04.0-2.fc24, kdegraphics-strigi-analyzer-16.04.0-2.fc24, kdelibs-4.14.19-3.fc24, kdepimlibs-4.14.10-13.fc24, kolourpaint-16.04.0-2.fc24, ksaneplugin-16.04.0-2.fc24, libkscreen-1.0.5-9.fc24, okular-16.04.0-2.fc24, phonon-4.8.3-12.fc24, plasma-breeze-5.6.3-2.fc24, plasma-oxygen-5.6.3-2.fc24, qca-2.1.1-6.fc24, qscintilla-2.9.2-3.fc24, qt-4.8.7-17.fc24, svgpart-16.04.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.