Bug 1329492 - Peers goes to rejected state after reboot of one node when quota is enabled on cloned volume.
Summary: Peers goes to rejected state after reboot of one node when quota is enabled o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.11
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1308837 1316848
Blocks: 1268895
TreeView+ depends on / blocked
 
Reported: 2016-04-22 05:55 UTC by Avra Sengupta
Modified: 2016-06-28 12:14 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1316848
Environment:
Last Closed: 2016-06-28 12:14:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-22 05:55:51 UTC
REVIEW: http://review.gluster.org/14047 (snapshot/quota: Copy quota.cksum during snapshot operations) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-04-26 15:58:23 UTC
COMMIT: http://review.gluster.org/14047 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 3c5586b3e8772f0a9d25502c9b4474e987ecc656
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Mar 11 15:27:30 2016 +0530

    snapshot/quota: Copy quota.cksum during snapshot operations
    
        Backport of http://review.gluster.org/#/c/13760/
    
    A volume having a quota.conf file, should always have
    a quota.cksum file too. Based on this above assumption
    modifying glusterd_copy_quota_files() to always copy
    quota.cksum, if quota.conf is present.
    
    This change will be reflected when a snapshot is created,
    restored and cloned.
    
    Change-Id: Ia49dc26eacef32eeb8f7d7d9553c80e304b08779
    BUG: 1329492
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13760
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    (cherry picked from commit 8f3ad1e3ede77fa5f8c8d606e18a7e83865a822c)
    Reviewed-on: http://review.gluster.org/14047

Comment 3 Kaushal 2016-06-28 12:14:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.