Bug 1329613 - bananapi: unable to pxe boot
Summary: bananapi: unable to pxe boot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs
Depends On:
Blocks: F24BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-22 11:26 UTC by Lukas Brabec
Modified: 2016-04-25 09:01 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-04-25 09:01:33 UTC


Attachments (Terms of Use)
screenshot 1 (85.34 KB, image/jpeg)
2016-04-22 11:26 UTC, Lukas Brabec
no flags Details
screenshot 2 (112.58 KB, image/jpeg)
2016-04-22 11:26 UTC, Lukas Brabec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1314092 None None None Never

Internal Trackers: 1314092

Description Lukas Brabec 2016-04-22 11:26:16 UTC
Created attachment 1149726 [details]
screenshot 1

I'm not able to do PXE boot on Banana Pi. Initrd, kernel and dtb file are loaded as always and system starts to boot. Then it hangs for a while when systemd reaches target basic system (see screenshot 1). After that I see long list of 
warning: dracut-initqueue timeout - starting timeout scripts. Finally I got message "could not boot" and "/dev/root does not exist" and dracut shell is shown but for some reason keyboard doesn't work (see screenshot 2).

The vmlinuz is from 2016-04-13 and initrd from 2016-04-21. PXE configuration:
  KERNEL Fedora/24/latest/armhfp/vmlinuz
  INITRD Fedora/24/latest/armhfp/initrd.img
  FDT    Fedora/24/latest/armhfp/dtb/sun7i-a20-bananapi.dtb
  APPEND inst.repo=http://dl.fedoraproject.org/pub/fedora/linux/development/24/Everything/armhfp/os/ console=ttyAMA0 console=tty0

Comment 1 Lukas Brabec 2016-04-22 11:26 UTC
Created attachment 1149727 [details]
screenshot 2

Comment 2 Fedora Blocker Bugs Application 2016-04-22 11:50:08 UTC
Proposed as a Blocker for 24-beta by Fedora user lbrabec using the blocker tracking app because:

 This bug violates beta criterion: Direct kernel boot - It must be possible to install by booting the installation kernel directly (including via PXE) and correctly specifying a remote source for the installer itself.

Comment 3 Kamil Páral 2016-04-22 13:31:28 UTC
This might be caused by bug 1314092 (the device has 1 GB RAM). Lukas tried booting into text mode and that worked.

Comment 4 Paul Whalen 2016-04-22 19:01:02 UTC
I think this can be closed, we were both able to pxe boot with vnc and text options. Graphical is also working here, but for some reason not for Lukas.


Note You need to log in before you can comment on or make changes to this bug.