Bug 132962 - Aiptek Pencam Ultra can freeze kernel
Summary: Aiptek Pencam Ultra can freeze kernel
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-20 14:15 UTC by Armijn Hemel
Modified: 2015-01-04 22:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 05:47:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Armijn Hemel 2004-09-20 14:15:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
If I attach an Aiptek Pencam Ultra to my system, run gnomemeeting,
detach the camera and then kill gnomemeeting, my machine freezes. I've
tested it with two different hardware configurations, one Dell
Optiplex GX260 and a Medion MD-8080.

The Aiptek Pencam Ultra uses the stv680 driver. I tried the same thing
with an old Logitech Quickcam (USB), but when I repeated the same
steps I did not have a problem.

The system freezes completely, there is no oops or anything else in
the logs.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. attach aiptek pencam ultra to machine
2. run gnomemeeting
3. detach the aiptek pencam ultra
4 . kill -9 <pid of gnomemeeting>
    

Actual Results:  machine freezes

Expected Results:  gnomemeeting should just be killed and nothing else

Additional info:

Comment 1 Armijn Hemel 2004-09-22 07:33:27 UTC
Just as a test I installed kernel 2.6.8-1.584from fc3t2, with exactly
the same result: I can still freeze my machine.

Comment 2 Dave Jones 2005-04-16 05:47:47 UTC
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.