Bug 1329628 - vte: Please update to the latest upstream version
Summary: vte: Please update to the latest upstream version
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PYTHON3
TreeView+ depends on / blocked
 
Reported: 2016-04-22 12:14 UTC by Tomas Orsava
Modified: 2016-04-22 15:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-22 15:13:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Orsava 2016-04-22 12:14:23 UTC
Please update vte to the latest upstream version.

I'm marking this as blocking the Python 3 Porting bug, because currently this package depends on Python 2, whereas the newest version doesn't depend on Python at all.

Comment 1 Kevin Fenzi 2016-04-22 14:52:14 UTC
There is no latest upstream for vte. It's a legacy package.

The latest versions are packaged in Fedora as vte3. 

In order to get rid of vte, we would need to get all the stuff that uses it moved to vte3 or the like. 

There are less things than there used to be. 

% sudo dnf repoquery --whatrequires 'libvte.so.9()(64bit)' --alldeps
Last metadata expiration check: 2:26:23 ago on Fri Apr 22 06:24:16 2016.
amtterm-0:1.4-2.fc24.x86_64
geany-plugins-debugger-0:1.27-1.fc25.x86_64
geany-plugins-geanypy-0:1.27-1.fc25.x86_64
geany-plugins-multiterm-0:1.27-1.fc25.x86_64
geany-plugins-scope-0:1.27-1.fc25.x86_64
gnome-desktop-sharp-0:2.26.0-28.fc24.x86_64
gnome-genius-0:1.0.20-4.fc24.x86_64
gnome-mud-0:0.11.2-17.fc24.x86_64
gnurobots-0:1.2.0-17.fc24.x86_64
grip-1:3.2.0-50.fc24.x86_64
gtkdialog-0:0.8.3-10.fc24.x86_64
gtkterm-0:0.99.7-0.8.rc1.git26021e33.fc24.x86_64
libvtemm-0:0.25.0-11.fc24.x86_64
lilyterm-0:0.9.9.2-7.fc24.x86_64
lxterminal-0:0.2.0-4.D20151126gitbe658ad3.fc24.x86_64
mate-terminal-0:1.14.0-1.fc25.x86_64
perl-Gnome2-Vte-0:0.11-2.fc24.x86_64
rasmol-gtk-0:2.7.5.2-6.fc24.x86_64
rubygem-vte-0:3.0.8-1.fc25.x86_64
stjerm-0:0.18-6.fc24.x86_64
termit-0:2.9.6-8.fc24.x86_64
vte-0:0.28.2-17.fc24.x86_64
vte-devel-0:0.28.2-17.fc24.x86_64
xfce4-terminal-0:0.6.3-9.fc24.x86_64

Comment 2 Tomas Orsava 2016-04-22 15:13:03 UTC
Ah, thank you for the info and sorry for the misfiled bug!

Have a good day!


Note You need to log in before you can comment on or make changes to this bug.