Bug 132963 - Installing/upgrading gives "/" on popd in %post script
Summary: Installing/upgrading gives "/" on popd in %post script
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-20 14:46 UTC by Nils Philippsen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 16:22:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2004-09-20 14:46:10 UTC
Installing/upgrading kernel packages produces a stray "/" when run
from the command line:

[root@ls3505 RPMS]# rpm -ivh kernel-2.6.8-1.541.i686.rpm
kernel-smp-2.6.8-1.541.i686.rpm
warning: kernel-2.6.8-1.541.i686.rpm: V3 DSA signature: NOKEY, key ID
30c9ecf8
Preparing...               
########################################### [100%]
   1:kernel-smp            
########################################### [ 50%]
/
   2:kernel                
########################################### [100%]
/
[root@ls3505 RPMS]# 

The problem is in the %post scripts which don't redirect popd's stdout
to /dev/null.

Comment 1 Arjan van de Ven 2004-09-20 16:22:14 UTC
fixed in current kernels


Note You need to log in before you can comment on or make changes to this bug.