Bug 1329641 - [RFE]Ceph/RBD block driver for qemu-kvm : change error_setg() to error_setg_errno()
Summary: [RFE]Ceph/RBD block driver for qemu-kvm : change error_setg() to error_setg_e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jeff Cody
QA Contact: jingzhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-22 12:45 UTC by Vikhyat Umrao
Modified: 2019-10-10 11:56 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-11.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:05:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
upstream patch in mater branch of qemu (4.48 KB, patch)
2016-04-22 13:01 UTC, Vikhyat Umrao
no flags Details | Diff
upstream patch in master branch of qemu (4.09 KB, patch)
2016-04-23 06:37 UTC, Vikhyat Umrao
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15308 None None None 2016-04-22 13:13:39 UTC
Red Hat Bugzilla 1321570 None ASSIGNED [RFE] LIBRADOS modify Pipe::connect() to return the error code 2019-09-10 03:19:44 UTC
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Internal Links: 1321570

Description Vikhyat Umrao 2016-04-22 12:45:12 UTC
Description of problem:
[RFE]Ceph/RBD block driver for qemu-kvm : change error_setg() to error_setg_errno()

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-31.el7_2.7.x86_64

Comment 1 Vikhyat Umrao 2016-04-22 13:01:19 UTC
Created attachment 1149750 [details]
upstream patch in mater branch of qemu

Comment 2 Vikhyat Umrao 2016-04-22 13:02:39 UTC
(In reply to Vikhyat Umrao from comment #1)
> Created attachment 1149750 [details]
> upstream patch in mater branch of qemu

I am planning to send this patch as given in comment#1. Please let me know your inputs.

Comment 3 Vikhyat Umrao 2016-04-23 06:37:49 UTC
Created attachment 1149969 [details]
upstream patch in master branch of qemu

Got some feedback from my Ceph RBD team. Uploading new patch set. Please ignore comment#1 patch.

Comment 8 Vikhyat Umrao 2016-05-09 08:18:26 UTC
Upstream Patch V2 : http://lists.nongnu.org/archive/html/qemu-devel/2016-05/msg01071.html

Comment 9 Miroslav Rezanina 2016-07-01 08:24:00 UTC
Fix included in qemu-kvm-rhev-2.6.0-11.el7

Comment 11 jingzhao 2016-08-24 08:44:05 UTC
Hi jeff
  
  Could you share detailed steps with QE?

Thanks
Jing Zhao

Comment 12 Jeff Cody 2016-09-02 15:23:13 UTC
Hi Jing Zhao,

Yes - the difference is in the error reporting. An easy way to reproduce is with an invalid qemu-img create:


Prior to the patch:
# qemu-img create -f qcow2 rbd:foo/bar 10M
[...]
qemu-img: rbd:foo/bar: error connecting

After the patch:
# qemu-img create -f qcow2 rbd:foo/bar 10M
[...]
qemu-img: rbd:foo/bar: error connecting: No such file or directory

Comment 13 jingzhao 2016-09-06 06:28:23 UTC
Hi Jeff

  Following is the my test result. Could you help check.

[root@ibm-x3100m4-02 ceph]# ceph osd lspools
0 rbd,1 libvirt-pool,
[root@ibm-x3100m4-02 ceph]# service ceph status
=== mon.ibm-x3100m4-02 === 
mon.ibm-x3100m4-02: running {"version":"0.94.9"}
=== osd.0 === 
osd.0: running {"version":"0.94.9"}
=== osd.1 === 
osd.1: running {"version":"0.94.9"}


1.Reproduce on qemu-kvm-rhev-2.3.0-31.el7_2.21.x86_64

[root@localhost ~]# qemu-img create -f raw rbd:libvirt-pool1/1.qcow2:mon_host=10.66.144.26 1G
qemu-img: rbd:libvirt-pool1/1.qcow2:mon_host=10.66.144.26: Unknown protocol 'rbd'

[root@localhost ~]# qemu-img create -f qcow2 rbd:libvirt-pool/1.qcow2:mon_host=10.66.144.26 1G
qemu-img: rbd:libvirt-pool/1.qcow2:mon_host=10.66.144.26: Unknown protocol 'rbd'


2. Test it on qemu-kvm-rhev-2.6.0-22.el7.x86_64

[root@jinzhao bug]# qemu-img create -f raw rbd:libvirt-pool1/1.qcow2:mon_host=10.66.144.26 1G
Formatting 'rbd:libvirt-pool1/1.qcow2:mon_host=10.66.144.26', fmt=raw size=1073741824
qemu-img: rbd:libvirt-pool1/1.qcow2:mon_host=10.66.144.26: error opening pool libvirt-pool1: No such file or directory

[root@jinzhao bug]# qemu-img create -f qcow2 rbd:libvirt-pool/2.qcow2:mon_host=10.66.144.26 1G
Formatting 'rbd:libvirt-pool/2.qcow2:mon_host=10.66.144.26', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
qemu-img: rbd:libvirt-pool/2.qcow2:mon_host=10.66.144.26: Could not write qcow2 header: Invalid argument


Is it verified?

Thanks
Jing Zhao

Comment 14 jingzhao 2016-09-06 06:29:40 UTC
Jeff, any comments for comment 13?

Thanks
Jing Zhao

Comment 15 Jeff Cody 2016-09-14 03:45:41 UTC
(In reply to jingzhao from comment #14)
> Jeff, any comments for comment 13?
> 
> Thanks
> Jing Zhao

Hi Jing,

Yes, this looks verified to me.  Thanks!

Comment 16 jingzhao 2016-09-14 05:12:19 UTC
According to comment13 and comment15, changed to verified

Comment 18 errata-xmlrpc 2016-11-07 21:05:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.