Bug 132970 - IBM eServer xSeries 345 fails to run kickstart, complaining about "/tmp/ks.cfg"
IBM eServer xSeries 345 fails to run kickstart, complaining about "/tmp/ks.cfg"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 11:15 EDT by John Borwick
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 22:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Borwick 2004-09-20 11:15:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
We're trying to set up PXE installation of some IBM eServer xSeries
345s.  We get to pxelinux's loading of the drivers, but it fails to
gain network connectivity... probably because of the e1000 driver.  We
get an SIOCSIFADDR error when the machine tries to use the interface,
and the "can't find /tmp/ks.cfg" error on the main screen.  We've
tried several different initrd images for the PXE boot (2.1 plain,
update 3, update 5, a hacked version w/o e1000).

Is this a case of initrd using the wrong driver?  Is it related to bug
110036 and DHCP?  Is there a way to override the e1000 guess (perhaps
to use tg3) with PXE?

Not that it matters, but we're using our satellite RHN server for the
installation, and I can verify that no connections are made from the
kickstart machine to the web server.

Thanks!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. buy IBM eServer xSeries 345
2. PXE boot with RHAS2.1 initrd image (vanilla, update 3, update 5)
    

Actual Results:  Can't load "/tmp/ks.cfg"

Expected Results:  Load network kickstart file

Additional info:
Comment 1 Jeremy Katz 2004-09-20 11:53:14 EDT
If you do a manual install, does it work?
Comment 2 John Borwick 2004-09-20 14:06:51 EDT
Thanks.  I tested the RHAS2.1U5 install--it worked--and I started
poking around some more.

I was using the correct initrd but not the correct vmlinuz.
Comment 3 Jeremy Katz 2004-09-20 22:15:30 EDT
Newer releases have a nice way to handle this but it couldn't be done
for older releases without breaking some things others depended on.

Note You need to log in before you can comment on or make changes to this bug.