Bug 132974 - Multiple Activation keys not working on Satellite 3.4
Multiple Activation keys not working on Satellite 3.4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
: 125542 (view as bug list)
Depends On:
Blocks: 135427
  Show dependency treegraph
 
Reported: 2004-09-20 11:32 EDT by Nick Strugnell
Modified: 2007-07-31 10:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 18:31:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2004-09-20 11:32:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303

Description of problem:
 We have a problem with multiple activation keys.

We have 2 activation keys, one key associates to one configuration
channels, the other key associates to a different configuration channel.

The two configuration channels do not have _any_ files in common.

However, when we try to activate we get:

[root@clx01af01 rhn]# rhnreg_ks
--activationkey=174af2009cf47d02395e434a774f9acd,a96ec733fd733d45a56146757688bdf3

Error Message:
   Conflicting configuration channels for tokens `BladeCenter ES Test'
and `RHEL 3 ES Test Key'
Error Class Code: 63
Error Class Info: Conflicting activation tokens

See IT# 49007

Version-Release number of selected component (if applicable):
RHN 3.4

How reproducible:
Always

Steps to Reproduce:
1.Create activation keys with different config channels associated
with them
2.Use rhnreg_ks to activate using the keys
3.
    

Actual Results:  key conflict, even though config channels contain
different files

Expected Results:  no key conflict

Additional info:
Comment 1 Mihai Ibanescu 2004-09-21 15:52:25 EDT
This has been fixed in CVS. 
Comment 2 Todd Warner 2004-09-23 18:47:45 EDT
So... does that mean this should be MODIFIED?
Let's get packages built and this stuff in ON_QA.
Comment 5 Mihai Ibanescu 2004-10-07 00:25:46 EDT
*** Bug 125542 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.