Bug 1329779 - Inode leaks found in data-self-heal
Summary: Inode leaks found in data-self-heal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.7.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1329773 1330881
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-23 00:13 UTC by Pranith Kumar K
Modified: 2016-06-28 12:14 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1329773
Environment:
Last Closed: 2016-06-28 12:14:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-04-23 00:13:07 UTC
+++ This bug was initially created as a clone of Bug #1329773 +++

Description of problem:
Olia found inode leak in the review @ https://github.com/gluster/glusterfs/commit/b8106d1127f034ffa88b5dd322c23a10e023b9b6

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-04-22 20:11:53 EDT ---

REVIEW: http://review.gluster.org/14052 (cluster/afr: Fix inode-leak in data self-heal) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 1 Vijay Bellur 2016-04-23 00:14:14 UTC
REVIEW: http://review.gluster.org/14053 (cluster/afr: Fix inode-leak in data self-heal) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-04-25 18:17:04 UTC
REVIEW: http://review.gluster.org/14053 (cluster/afr: Fix inode-leak in data self-heal) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Vijay Bellur 2016-04-26 02:30:23 UTC
COMMIT: http://review.gluster.org/14053 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 32b03257c16aa44dd98377a84208c8a5fdb9b2ef
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat Apr 23 05:30:08 2016 +0530

    cluster/afr: Fix inode-leak in data self-heal
    
    Thanks to Olia-Kremmyda for finding the bug on github review,
    https://github.com/gluster/glusterfs/commit/b8106d1127f034ffa88b5dd322c23a10e023b9b6
    
     >Change-Id: Ib8640ed0c331a635971d5d12052f0959c24f76a2
     >BUG: 1329773
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/14052
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
     >Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    
    BUG: 1329779
    Change-Id: I3d77f0b445fdedf2c582ea88f8d89e1da525638f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14053
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>

Comment 4 Kaushal 2016-06-28 12:14:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.