Bug 132979 - exporting DISPLAY via hostname fails
exporting DISPLAY via hostname fails
Status: CLOSED DUPLICATE of bug 134883
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 12:22 EDT by Matt Jamison
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 07:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Jamison 2004-09-20 12:22:57 EDT
from customer:

Here is what we are seeing on RedHat 64bit 3.0 (update 2 and update 3)

We can set our DISPLAY variable to an IP address and we can get the X
display back from the server.  But when we set the DISPLAY to use our
hostname, we cannot get x display.  We do not see any DNS problem
issue -  forward and reverse lookups work.  Our hostnames start with
numeric and then followed by alphabets, e.g., 50dhcp24 where the first
2 digits represent the subnet.  

If we change our DNS naming to start with alpha (e.g., dhcp50) the X
Display works fine.  It is difficult to undertake this type of change
as this requires management approval.

This problem is not occurring on RH 3.0 32 bit (or older versions),
Solaris and HPs.  This problem can be replicated easily.
Comment 2 Mike A. Harris 2004-09-21 01:28:04 EDT
Does this problem only occur if the hostname is changed while the
X server is running, or does it also occur if you do a full system
reboot, in which the machine's hostname gets assigned via DHCP
on system startup, prior to the X server starting?

Thanks in advance.

Setting problem status to "NEEDINFO".
Comment 3 Matt Jamison 2004-09-21 13:04:58 EDT
from customer:

The problem seems to be how the X server resolves the client hostname,
in this case our PCs with DHCP assigned addresses.
This problem occurs everytime the client hostname starts with a
number.  If I  define my pc's address (to start with an alphabet) in
the /etc/hosts file and make the corresponding change in the
/etc/nsswitch.conf (to override DNS name resolution and use local
file), the display works.  I get a display back if I set my client PC
(runningThe DISPLAY variable to an IP address.  It does not seem to be
a problem with the DNS, we can do forward and reverse lookups without
any problems.

The problem is always reproducible.  


I went and checked RH's bugzilla all day yesterday but did not find
anything close to what we are seeing here. This is kind of holding us
back in rolling-out our 64-bit machines with update 3 patches.

Comment 4 Matt Jamison 2004-09-23 18:01:57 EDT
any update?
Comment 5 Mike A. Harris 2005-02-01 06:20:53 EST
Bug #134883 appears to be the same issue, along with:

https://freedesktop.org/bugzilla/show_bug.cgi?id=1605

Comment 7 Mike A. Harris 2005-04-15 07:04:13 EDT

*** This bug has been marked as a duplicate of 134883 ***

Note You need to log in before you can comment on or make changes to this bug.