Bug 1329854 - SELinux is preventing firewalld from 'write' accesses on the directory /root.
Summary: SELinux is preventing firewalld from 'write' accesses on the directory /root.
Keywords:
Status: CLOSED DUPLICATE of bug 1340611
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 24
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e584e72970593ac9ee2a05fac83...
: 1368799 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-23 21:41 UTC by Paula
Modified: 2016-08-21 13:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 12:31:14 UTC


Attachments (Terms of Use)

Description Paula 2016-04-23 21:41:43 UTC
Description of problem:
SELinux is preventing firewalld from 'write' accesses on the directory /root.

*****  Plugin catchall (100. confidence) suggests   **************************

If cree que de manera predeterminada, firewalld debería permitir acceso write sobre root directory.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
allow this access for now by executing:
# ausearch -c firewalld --raw | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:firewalld_t:s0
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        firewalld
Source Path                   firewalld
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.2-37.fc24.x86_64
Policy RPM                    selinux-policy-3.13.1-182.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc7.git0.2.fc24.x86_64 #1
                              SMP Tue Mar 8 02:20:08 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-04-23 14:32:47 PDT
Last Seen                     2016-04-23 14:32:47 PDT
Local ID                      ab0399c1-6847-4104-a7b6-93af8239bb0f

Raw Audit Messages
type=AVC msg=audit(1461447167.221:742): avc:  denied  { write } for  pid=11485 comm="firewalld" name="root" dev="dm-0" ino=1966081 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir permissive=0


Hash: firewalld,firewalld_t,admin_home_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-182.fc24.noarch

Additional info:
reporter:       libreport-2.7.0
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
reproducible:   Not sure how to reproduce the problem
type:           libreport

Comment 1 Martijn Kruiten 2016-05-03 10:34:38 UTC
Description of problem:
- fresh install of Fedora 24 alpha (downloaded may 3, 2016)
- dnf update
- firewalld attempts to write but is prevented by SELinux

Version-Release number of selected component:
selinux-policy-3.13.1-184.fc24.noarch

Additional info:
reporter:       libreport-2.7.0
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
reproducible:   Not sure how to reproduce the problem
type:           libreport

Comment 2 Lukas Vrabec 2016-06-02 12:31:14 UTC

*** This bug has been marked as a duplicate of bug 1340611 ***

Comment 3 Ege Meriç ERDOĞAN 2016-08-21 13:19:44 UTC
*** Bug 1368799 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.